summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-05-06 17:16:10 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-05-06 17:16:25 -0700
commitb8ac5bbac1921cd193bd65b4af23c5b1953ce9b8 (patch)
tree98edebad21a3ee94554cedc9b580585a75d6de17 /dev-python/sphinxcontrib-httpexample
parentdev-python/snapshottest: New package (diff)
downloadgentoo-b8ac5bbac1921cd193bd65b4af23c5b1953ce9b8.tar.gz
gentoo-b8ac5bbac1921cd193bd65b4af23c5b1953ce9b8.tar.bz2
gentoo-b8ac5bbac1921cd193bd65b4af23c5b1953ce9b8.zip
dev-python/sphinxcontrib-httpexample: New package
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/sphinxcontrib-httpexample')
-rw-r--r--dev-python/sphinxcontrib-httpexample/Manifest1
-rw-r--r--dev-python/sphinxcontrib-httpexample/metadata.xml16
-rw-r--r--dev-python/sphinxcontrib-httpexample/sphinxcontrib-httpexample-0.10.3.ebuild44
3 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-httpexample/Manifest b/dev-python/sphinxcontrib-httpexample/Manifest
new file mode 100644
index 000000000000..fe36e3692959
--- /dev/null
+++ b/dev-python/sphinxcontrib-httpexample/Manifest
@@ -0,0 +1 @@
+DIST sphinxcontrib-httpexample-0.10.3.tar.gz 30489 BLAKE2B 1100f28398d0d23559fb7ebea8263be5da6f2db09e9d5f48513d80d2cd580d2ff436df84b532eba8fb0c30eb3787a86f57f75750aeb0857b52af09885ba9a124 SHA512 de776f20e566a5b2ec4fcbad82d2ac39988ccf651a14d38d353dfd9cda7c15289acbb41db56df9189e42c2637bfd70fd4915d19d4ee718ddd4de476ddc34151f
diff --git a/dev-python/sphinxcontrib-httpexample/metadata.xml b/dev-python/sphinxcontrib-httpexample/metadata.xml
new file mode 100644
index 000000000000..39ac3a9a9590
--- /dev/null
+++ b/dev-python/sphinxcontrib-httpexample/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>williamh@gentoo.org</email>
+ <name>William Hubbs</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>vpayno+gentoo@gmail.com</email>
+ <name>Victor Payno</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/sphinxcontrib-httpexample/sphinxcontrib-httpexample-0.10.3.ebuild b/dev-python/sphinxcontrib-httpexample/sphinxcontrib-httpexample-0.10.3.ebuild
new file mode 100644
index 000000000000..62cfbf4fe443
--- /dev/null
+++ b/dev-python/sphinxcontrib-httpexample/sphinxcontrib-httpexample-0.10.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Adds example directive for sphinx-contrib httpdomain"
+HOMEPAGE="https://github.com/collective/sphinxcontrib-httpexample"
+SRC_URI="https://github.com/collective/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/astunparse[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-httpdomain[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}
+ test? (
+ dev-python/snapshottest[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ dev-python/sphinx-testing[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -e "s:pytest-runner::" -i setup.cfg || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ distutils_install_for_testing
+ pytest -vv || die "tests fail with ${EPYTHON}"
+}