summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-03 18:20:16 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-03 18:30:55 +0100
commit565ca0af60af3ebbcff21176223eed98fcc6839c (patch)
treef89ef814d3f94ae7615349f04297a4c282d7e66d /dev-python/sphinxcontrib-jsmath/sphinxcontrib-jsmath-1.0.1-r2.ebuild
parentdev-python/sphinxcontrib-issuetracker: Remove namespace dep (diff)
downloadgentoo-565ca0af60af3ebbcff21176223eed98fcc6839c.tar.gz
gentoo-565ca0af60af3ebbcff21176223eed98fcc6839c.tar.bz2
gentoo-565ca0af60af3ebbcff21176223eed98fcc6839c.zip
dev-python/sphinxcontrib-jsmath: Remove namespace dep
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinxcontrib-jsmath/sphinxcontrib-jsmath-1.0.1-r2.ebuild')
-rw-r--r--dev-python/sphinxcontrib-jsmath/sphinxcontrib-jsmath-1.0.1-r2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-jsmath/sphinxcontrib-jsmath-1.0.1-r2.ebuild b/dev-python/sphinxcontrib-jsmath/sphinxcontrib-jsmath-1.0.1-r2.ebuild
new file mode 100644
index 000000000000..fa7fd701b6a2
--- /dev/null
+++ b/dev-python/sphinxcontrib-jsmath/sphinxcontrib-jsmath-1.0.1-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extension which renders display math in HTML via JavaScript"
+HOMEPAGE="https://www.sphinx-doc.org
+ https://github.com/sphinx-doc/sphinxcontrib-jsmath"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
+
+PDEPEND="
+ >=dev-python/sphinx-2.0[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? ( ${PDEPEND} )"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}