summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-20 12:13:18 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-20 14:18:23 +0200
commit2f3ae08c158a7ad764b424ceca05812e63b6b625 (patch)
treef383a555fbf6a51deca716e554d145179993f327 /dev-python/sphinxcontrib-newsfeed
parentdev-python/sphinxcontrib-log_cabinet: EAPI 8, PEP517, rm namespace dep (diff)
downloadgentoo-2f3ae08c158a7ad764b424ceca05812e63b6b625.tar.gz
gentoo-2f3ae08c158a7ad764b424ceca05812e63b6b625.tar.bz2
gentoo-2f3ae08c158a7ad764b424ceca05812e63b6b625.zip
dev-python/sphinxcontrib-newsfeed: EAPI 8, PEP517, rm namespace dep
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinxcontrib-newsfeed')
-rw-r--r--dev-python/sphinxcontrib-newsfeed/sphinxcontrib-newsfeed-0.1.4-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-newsfeed/sphinxcontrib-newsfeed-0.1.4-r1.ebuild b/dev-python/sphinxcontrib-newsfeed/sphinxcontrib-newsfeed-0.1.4-r1.ebuild
new file mode 100644
index 000000000000..f58fad9eb3dd
--- /dev/null
+++ b/dev-python/sphinxcontrib-newsfeed/sphinxcontrib-newsfeed-0.1.4-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="News Feed extension for Sphinx"
+HOMEPAGE="
+ https://github.com/prometheusresearch/sphinxcontrib-newsfeed/
+ https://pypi.org/project/sphinxcontrib-newsfeed/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+RDEPEND="
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ docinto examples
+ dodoc -r demo/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}