summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-31 19:12:57 +0100
committerMichał Górny <mgorny@gentoo.org>2023-10-31 20:12:30 +0100
commit3b9bc0798128b1ddf1bcdc121bebe0cbda06d3e4 (patch)
treef0c6c7ed0013b5b7bf83ebe0cc754645934f0f7c /dev-python/sphinxcontrib-plantuml
parentdev-python/ipython: Bump to 8.17.2 (diff)
downloadgentoo-3b9bc0798128b1ddf1bcdc121bebe0cbda06d3e4.tar.gz
gentoo-3b9bc0798128b1ddf1bcdc121bebe0cbda06d3e4.tar.bz2
gentoo-3b9bc0798128b1ddf1bcdc121bebe0cbda06d3e4.zip
dev-python/sphinxcontrib-plantuml: Bump to 0.27
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinxcontrib-plantuml')
-rw-r--r--dev-python/sphinxcontrib-plantuml/Manifest1
-rw-r--r--dev-python/sphinxcontrib-plantuml/sphinxcontrib-plantuml-0.27.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-plantuml/Manifest b/dev-python/sphinxcontrib-plantuml/Manifest
index 288744257cb1..209ae27e59e5 100644
--- a/dev-python/sphinxcontrib-plantuml/Manifest
+++ b/dev-python/sphinxcontrib-plantuml/Manifest
@@ -1,2 +1,3 @@
DIST sphinxcontrib-plantuml-0.25.gh.tar.gz 18871 BLAKE2B 563cedb9c67303b08e71019f5ca21385a7ef6fd65b07eed01710c83776742868a18aa01346c2dcb7c9121693ec15f9181c610bd39432042812c891423dd0d3f8 SHA512 1f04ccfd1f8cedea22a0bd8d445e298d461c253d75f92a757c55ae013fa5043327312021f4915a15e522a5409d92217ac76865e7a520512c190ba3e6e5642f08
DIST sphinxcontrib-plantuml-0.26.gh.tar.gz 19112 BLAKE2B 65d4cca560cbc52271f22cfd479937b872d8bd58f72ac778aab873b5528312ccacc368328f65b29e437445080b9ca65a835019fe5cba38aac7488c5b3e03a6d9 SHA512 1ec004012d4eaeda0f0299206b6cbc1cbd246f378123d067912baf5b2f9c10ecffa4e27778d34db89dde84eff183fbeff35793420971cb94f42fa416af37786f
+DIST sphinxcontrib-plantuml-0.27.gh.tar.gz 19268 BLAKE2B d74d85da40a9c17eb6d73bfd2890af4f4260b11001bba4f3001d84f2f9b53597c2148c14af5a853ab3c0d3a760435a3475c6bc69748c9522f66b5f1c5e01d7b2 SHA512 acf648bc83647317d717c7f69026f20cc87066e26c409daaf14ec35e874f53ba324d1b2325b82987bc54f8224293113997bbfeca78b9f14c1704ff108e083faf
diff --git a/dev-python/sphinxcontrib-plantuml/sphinxcontrib-plantuml-0.27.ebuild b/dev-python/sphinxcontrib-plantuml/sphinxcontrib-plantuml-0.27.ebuild
new file mode 100644
index 000000000000..d4636449c967
--- /dev/null
+++ b/dev-python/sphinxcontrib-plantuml/sphinxcontrib-plantuml-0.27.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extensions for PlantUML"
+HOMEPAGE="
+ https://github.com/sphinx-contrib/plantuml/
+ https://pypi.org/project/sphinxcontrib-plantuml/
+"
+SRC_URI="
+ https://github.com/sphinx-contrib/plantuml/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+S="${WORKDIR}/${P#sphinxcontrib-}"
+
+BDEPEND="
+ test? (
+ app-text/texlive
+ dev-python/sphinxcontrib-applehelp[${PYTHON_USEDEP}]
+ dev-tex/latexmk
+ dev-texlive/texlive-fontutils
+ dev-texlive/texlive-latexextra
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # Fix for sphinx.errors.ExtensionError: Could not import extension sphinxcontrib.applehelp
+ # See https://projects.gentoo.org/python/guide/test.html#importerrors-for-c-extensions, thanks to mgorny.
+ rm -rf sphinxcontrib || die
+
+ epytest
+}