summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-02 15:57:01 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-02 16:16:38 +0100
commitaf81611a7e030cfcfffe12d83b21225a68e16379 (patch)
tree90958ca5643a688c0ed190c639dee82756fca0bb /dev-python/sphinxcontrib-qthelp/sphinxcontrib-qthelp-1.0.3.ebuild
parentdev-python/sphinxcontrib-serializinghtml: Bump to 1.1.4, add tests (diff)
downloadgentoo-af81611a7e030cfcfffe12d83b21225a68e16379.tar.gz
gentoo-af81611a7e030cfcfffe12d83b21225a68e16379.tar.bz2
gentoo-af81611a7e030cfcfffe12d83b21225a68e16379.zip
dev-python/sphinxcontrib-qthelp: Bump to 1.0.3, add tests
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinxcontrib-qthelp/sphinxcontrib-qthelp-1.0.3.ebuild')
-rw-r--r--dev-python/sphinxcontrib-qthelp/sphinxcontrib-qthelp-1.0.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-qthelp/sphinxcontrib-qthelp-1.0.3.ebuild b/dev-python/sphinxcontrib-qthelp/sphinxcontrib-qthelp-1.0.3.ebuild
new file mode 100644
index 000000000000..547437766943
--- /dev/null
+++ b/dev-python/sphinxcontrib-qthelp/sphinxcontrib-qthelp-1.0.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extension which outputs QtHelp documents"
+HOMEPAGE="https://www.sphinx-doc.org
+ https://github.com/sphinx-doc/sphinxcontrib-qthelp"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
+
+RDEPEND="dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]"
+PDEPEND="
+ >=dev-python/sphinx-2.0[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${PDEPEND} )"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}