summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-12 20:19:01 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-12 20:24:30 +0200
commit82c58d6f5fcbc936f7f34140118e47b31c7b9e52 (patch)
treefc823df640214e93e52346e5e2d518322357ca26 /dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-5.1.1.ebuild
parentdev-python/sphinxcontrib-spelling: Port to py3.9 (diff)
downloadgentoo-82c58d6f5fcbc936f7f34140118e47b31c7b9e52.tar.gz
gentoo-82c58d6f5fcbc936f7f34140118e47b31c7b9e52.tar.bz2
gentoo-82c58d6f5fcbc936f7f34140118e47b31c7b9e52.zip
dev-python/sphinxcontrib-spelling: Bump to 5.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-5.1.1.ebuild')
-rw-r--r--dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-5.1.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-5.1.1.ebuild b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-5.1.1.ebuild
new file mode 100644
index 000000000000..5b51077280e2
--- /dev/null
+++ b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-5.1.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx spelling extension"
+HOMEPAGE="https://github.com/sphinx-contrib/spelling"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ app-dicts/myspell-en
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source --no-autodoc
+distutils_enable_tests unittest
+
+RDEPEND+="
+ dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]
+"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}