summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-08-02 02:35:06 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-08-02 04:06:25 +0000
commitc0a4ccb703975d8b3b5c7b9655d214d4e80a1b70 (patch)
tree76ef998cbfb6215238d03895f0f5882720e3ac05 /dev-python/sphinxcontrib-spelling
parentdev-python/sphinxcontrib-programoutput: version bump (diff)
downloadgentoo-c0a4ccb703975d8b3b5c7b9655d214d4e80a1b70.tar.gz
gentoo-c0a4ccb703975d8b3b5c7b9655d214d4e80a1b70.tar.bz2
gentoo-c0a4ccb703975d8b3b5c7b9655d214d4e80a1b70.zip
dev-python/sphinxcontrib-spelling: version bump
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-python/sphinxcontrib-spelling')
-rw-r--r--dev-python/sphinxcontrib-spelling/Manifest1
-rw-r--r--dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-2.3.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-spelling/Manifest b/dev-python/sphinxcontrib-spelling/Manifest
index c54633f2dc2a..d0ad92c081d2 100644
--- a/dev-python/sphinxcontrib-spelling/Manifest
+++ b/dev-python/sphinxcontrib-spelling/Manifest
@@ -1 +1,2 @@
DIST sphinxcontrib-spelling-2.1.2.tar.gz 35411 SHA256 c5ac488141408564cb60f355c50efd90b826a9fc7723738a07ab907a0384f086 SHA512 993f371e064e8748eb61faae649fb293b154a35955ff84d86fd041f4e2cc4c6e22c686007a67c3b63b0c50fc01ed226708f27db347e58847a46ca733c997d51f WHIRLPOOL 3258a991dbeb36ee1a3da64c64d2f05a1978a2c9348be1c2112afaf0cb40414cfe5f139d199cad7f534ade40db61666c133d70bc0605bd878e414e1dbe0f7e6a
+DIST sphinxcontrib-spelling-2.3.0.tar.gz 35687 SHA256 008ec060f312367222992824abed00124cce0dd31c375a89b2053010df0e3be8 SHA512 194023d2c5ba594a264740a2a45ebd90d37fc17fbd3bc8c53fa303581a652c58332f998a159c9c6c58718dd9898c9b4639e98ee114a2ee1e5f2097e545134a1a WHIRLPOOL 644c066bcbf393b670082cae51a8278788a562e59112a4c47adb7e3e291e6f508254a05f4792148f44cefc835b28e7c51b1522842526480304c01d43da48e7b6
diff --git a/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-2.3.0.ebuild b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-2.3.0.ebuild
new file mode 100644
index 000000000000..4424910a7ac7
--- /dev/null
+++ b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-2.3.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx spelling extension"
+HOMEPAGE="https://bitbucket.org/dhellmann/sphinxcontrib-spelling"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+CDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+RDEPEND="${CDEPEND}
+ dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]
+"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}