summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-06-19 03:13:00 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-06-19 03:13:43 +0200
commit0abcb22f9712d1342df1de45e437310f0fadfa8c (patch)
tree9bf694356c452f9196659fbec6cc9d6ee0a8c9a8 /dev-python/spotipy
parentsys-devel/gcc: add 12.1.1_p20220618 (diff)
downloadgentoo-0abcb22f9712d1342df1de45e437310f0fadfa8c.tar.gz
gentoo-0abcb22f9712d1342df1de45e437310f0fadfa8c.tar.bz2
gentoo-0abcb22f9712d1342df1de45e437310f0fadfa8c.zip
dev-python/spotipy: bump to 2.20.0
now added redis-py dep, commit: https://github.com/plamere/spotipy/commit/7d23fc327723443c2c413da81758195ac54fc2b5 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-python/spotipy')
-rw-r--r--dev-python/spotipy/Manifest1
-rw-r--r--dev-python/spotipy/spotipy-2.20.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/spotipy/Manifest b/dev-python/spotipy/Manifest
index 12c83ee2269b..6a5da472b855 100644
--- a/dev-python/spotipy/Manifest
+++ b/dev-python/spotipy/Manifest
@@ -1 +1,2 @@
DIST spotipy-2.19.0.tar.gz 102703 BLAKE2B bc132edb972236b43097c0bbc9d86932a3305d8bd3807e44e20767b123455950b8e01060efd83c87b3a162e329f5c48614205f131686af7f9312a44894a7f1e7 SHA512 fbaecd1a2cab3ef458d30de46cb89462021dfc3cfc85516d8bfe509af016a0b19af2f8de4f5cae36188b1ce1f5718c75edff0e71af2a87f4d720ee99d4541a6a
+DIST spotipy-2.20.0.tar.gz 103437 BLAKE2B 78b026b9de04b0115c5621345e4f4c0ee47a51980221c77da8754c54fc8c321a1826983ceb9bcf9c415690906f3b3ea4657243e6b5d351d3edb48084baeca292 SHA512 8b5d0704fa84974ea0728dda0fe89d021b7b1550b464026d2b087671102745c7edcab116246399dd97de42d9c0cc7411295297c328b301712b6536aa6a3cd6fd
diff --git a/dev-python/spotipy/spotipy-2.20.0.ebuild b/dev-python/spotipy/spotipy-2.20.0.ebuild
new file mode 100644
index 000000000000..3409dd977e02
--- /dev/null
+++ b/dev-python/spotipy/spotipy-2.20.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A light weight Python library for the Spotify Web API"
+HOMEPAGE="https://spotipy.readthedocs.io"
+SRC_URI="https://github.com/plamere/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="examples"
+
+RDEPEND="
+ dev-python/redis-py[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+"
+BDEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Requires user credentials
+ rm tests/integration/test_user_endpoints.py || die
+
+ # Requires a spotify client ID
+ rm tests/integration/test_non_user_endpoints.py || die
+
+ # Needs internet access
+ sed -i -e 's:test_spotify_client_credentials_get_access_token:_&:' \
+ tests/unit/test_oauth.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ use examples && dodoc -r examples
+}