summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-12 14:16:59 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-12 14:18:36 +0100
commitf30f28b4583e6bb2b5dc8cb5de2dfd5b4e35b9c1 (patch)
treeeb1af81e147f8f62b5a4f79cd8e7b7d9d18939d1 /dev-python/spur/spur-0.3.23.ebuild
parentdev-python/pyscreenshot: Bump to 3.1 (diff)
downloadgentoo-f30f28b4583e6bb2b5dc8cb5de2dfd5b4e35b9c1.tar.gz
gentoo-f30f28b4583e6bb2b5dc8cb5de2dfd5b4e35b9c1.tar.bz2
gentoo-f30f28b4583e6bb2b5dc8cb5de2dfd5b4e35b9c1.zip
dev-python/spur: Bump to 0.3.23
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/spur/spur-0.3.23.ebuild')
-rw-r--r--dev-python/spur/spur-0.3.23.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/spur/spur-0.3.23.ebuild b/dev-python/spur/spur-0.3.23.ebuild
new file mode 100644
index 000000000000..0509591b08a2
--- /dev/null
+++ b/dev-python/spur/spur-0.3.23.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+MY_P=spur.py-${PV}
+DESCRIPTION="Run commands locally or over SSH using the same interface"
+HOMEPAGE="
+ https://github.com/mwilliamson/spur.py/
+ https://pypi.org/project/spur/
+"
+SRC_URI="
+ https://github.com/mwilliamson/spur.py/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ <dev-python/paramiko-4[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # TODO: set up a local SSH server?
+ tests/ssh_tests.py
+)