summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-01-14 12:47:27 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-02-19 09:02:43 +0200
commita544234847c2158661f039e842822f0812e9a53b (patch)
treec16495a3df5cdca860232ce7e8fda9a95b258636 /dev-python/spyder-line-profiler
parentdev-python/spyder: Clean up 4.0.0_beta versions (diff)
downloadgentoo-a544234847c2158661f039e842822f0812e9a53b.tar.gz
gentoo-a544234847c2158661f039e842822f0812e9a53b.tar.bz2
gentoo-a544234847c2158661f039e842822f0812e9a53b.zip
dev-python/spyder-line-profiler: Plugin to run the line profiler within spyder
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/spyder-line-profiler')
-rw-r--r--dev-python/spyder-line-profiler/Manifest1
-rw-r--r--dev-python/spyder-line-profiler/metadata.xml12
-rw-r--r--dev-python/spyder-line-profiler/spyder-line-profiler-0.2.0.ebuild30
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/spyder-line-profiler/Manifest b/dev-python/spyder-line-profiler/Manifest
new file mode 100644
index 000000000000..ce5d24d4486b
--- /dev/null
+++ b/dev-python/spyder-line-profiler/Manifest
@@ -0,0 +1 @@
+DIST spyder-line-profiler-0.2.0.tar.gz 70556 BLAKE2B 0f00c81b5598830a23df10ecbd23060e46218b39edfca80c06458da05a5b5f06ad644444f6876b5379a8cd2c4e590361c6061e22c0d70592fb8601e472a3b12c SHA512 302c5527834aae3ee940783170db08e436a311c4dee7bbbd51177c08ba8768af1c7b2d3a8af322d70dcfdb48f8e9ef86b0ccee4777ce4566e8579be98561eb94
diff --git a/dev-python/spyder-line-profiler/metadata.xml b/dev-python/spyder-line-profiler/metadata.xml
new file mode 100644
index 000000000000..8fc11184ab00
--- /dev/null
+++ b/dev-python/spyder-line-profiler/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrewammerlaan@riseup.net</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/spyder-line-profiler/spyder-line-profiler-0.2.0.ebuild b/dev-python/spyder-line-profiler/spyder-line-profiler-0.2.0.ebuild
new file mode 100644
index 000000000000..0845ccd887a6
--- /dev/null
+++ b/dev-python/spyder-line-profiler/spyder-line-profiler-0.2.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Plugin to run the python line profiler from within the spyder editor"
+HOMEPAGE="https://github.com/spyder-ide/spyder-line-profiler"
+SRC_URI="https://github.com/spyder-ide/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/line_profiler[${PYTHON_USEDEP}]
+ >=dev-python/spyder-4.0.0[${PYTHON_USEDEP}]"
+
+DEPEND="test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-qt[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ virtx pytest -vv spyder_line_profiler/widgets/tests
+}