summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-07-08 12:12:20 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-07-08 13:07:53 +0200
commit038d37725a01bed8b895cf670335191217da5e1b (patch)
tree42a4ce62e8dffbe36cb7e58d3641b58d8e9ffb6e /dev-python/spyder-notebook
parentdev-python/spyder-unittest: allow use of spyder-5 (diff)
downloadgentoo-038d37725a01bed8b895cf670335191217da5e1b.tar.gz
gentoo-038d37725a01bed8b895cf670335191217da5e1b.tar.bz2
gentoo-038d37725a01bed8b895cf670335191217da5e1b.zip
dev-python/spyder-notebook: remove version 0.3.2
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/spyder-notebook')
-rw-r--r--dev-python/spyder-notebook/spyder-notebook-0.3.2.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/dev-python/spyder-notebook/spyder-notebook-0.3.2.ebuild b/dev-python/spyder-notebook/spyder-notebook-0.3.2.ebuild
deleted file mode 100644
index de8761f5d3a7..000000000000
--- a/dev-python/spyder-notebook/spyder-notebook-0.3.2.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-
-inherit distutils-r1 virtualx
-
-DESCRIPTION="Jupyter notebook integration with Spyder"
-HOMEPAGE="https://github.com/spyder-ide/spyder-notebook"
-SRC_URI="https://github.com/spyder-ide/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/jupyter_core[${PYTHON_USEDEP}]
- dev-python/nbformat[${PYTHON_USEDEP}]
- dev-python/notebook[${PYTHON_USEDEP}]
- dev-python/psutil[${PYTHON_USEDEP}]
- dev-python/qdarkstyle[${PYTHON_USEDEP}]
- dev-python/QtPy[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- >=dev-python/spyder-4.1.0[${PYTHON_USEDEP}]
- <dev-python/spyder-5[${PYTHON_USEDEP}]
- dev-python/traitlets[${PYTHON_USEDEP}]
-"
-
-BDEPEND="test? (
- dev-python/flaky[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/pytest-qt[${PYTHON_USEDEP}]
-)"
-
-DOCS=( "README.md" "RELEASE.md" "CHANGELOG.md" "doc/example.gif" )
-
-# Tests do not work inside virtx/emerge for some reason, core dumped
-RESTRICT="test"
-distutils_enable_tests pytest
-
-python_test() {
- virtx pytest -vv
-}