summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-05-21 12:31:20 +0200
committerMatt Turner <mattst88@gentoo.org>2020-05-26 13:41:49 -0700
commitc004c4e23f56f1a62b3ed5e11484e789c1e65af1 (patch)
treeeb90fb720bbc5f707b5df92f8bea36550b6ddbd4 /dev-python/spyder-unittest/spyder-unittest-0.4.1.ebuild
parentdev-python/spyder-notebook: drop py3_6 (diff)
downloadgentoo-c004c4e23f56f1a62b3ed5e11484e789c1e65af1.tar.gz
gentoo-c004c4e23f56f1a62b3ed5e11484e789c1e65af1.tar.bz2
gentoo-c004c4e23f56f1a62b3ed5e11484e789c1e65af1.zip
dev-python/spyder-unittest: version bump and drop py3_6
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-python/spyder-unittest/spyder-unittest-0.4.1.ebuild')
-rw-r--r--dev-python/spyder-unittest/spyder-unittest-0.4.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/spyder-unittest/spyder-unittest-0.4.1.ebuild b/dev-python/spyder-unittest/spyder-unittest-0.4.1.ebuild
new file mode 100644
index 000000000000..5a999c55cae6
--- /dev/null
+++ b/dev-python/spyder-unittest/spyder-unittest-0.4.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_7 )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Plugin for Spyder to run tests and view the results"
+HOMEPAGE="https://github.com/spyder-ide/spyder-unittest"
+SRC_URI="https://github.com/spyder-ide/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-python/spyder-4.0.0[${PYTHON_USEDEP}]
+ dev-python/pyzmq[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]"
+
+DEPEND="test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pytest-qt[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ spyder_unittest_test() {
+ # fails to test in ${BUILDIR}/lib
+ # test do work if executed directly in the extracted tarball
+ local PYTHONPATH="${WORKDIR}/${P}"
+ pytest -vv spyder_unittest/tests spyder_unittest/widgets/tests
+ }
+
+ virtx spyder_unittest_test
+}