summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2018-08-14 20:47:37 +0700
committerAndrey Grozin <grozin@gentoo.org>2018-08-14 20:47:37 +0700
commit593bf3bd848ad32e9da73ddbd34f3350a07102f3 (patch)
treeeef8b37b86cb745ed2764c121493c5c87d527730 /dev-python/spyder/files
parentdev-python/python-debian: add python3.7 (diff)
downloadgentoo-593bf3bd848ad32e9da73ddbd34f3350a07102f3.tar.gz
gentoo-593bf3bd848ad32e9da73ddbd34f3350a07102f3.tar.bz2
gentoo-593bf3bd848ad32e9da73ddbd34f3350a07102f3.zip
gentoo/dev-python/spyder: bump to 3.3.1
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'dev-python/spyder/files')
-rw-r--r--dev-python/spyder/files/spyder-3.3.1-build.patch49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/spyder/files/spyder-3.3.1-build.patch b/dev-python/spyder/files/spyder-3.3.1-build.patch
new file mode 100644
index 000000000000..1561dbdcc1e1
--- /dev/null
+++ b/dev-python/spyder/files/spyder-3.3.1-build.patch
@@ -0,0 +1,49 @@
+diff -r -U3 spyder-3.3.1.orig/setup.py spyder-3.3.1/setup.py
+--- spyder-3.3.1.orig/setup.py 2018-08-10 10:46:02.000000000 +0700
++++ spyder-3.3.1/setup.py 2018-08-14 19:16:10.921323804 +0700
+@@ -83,12 +83,7 @@
+ def get_data_files():
+ """Return data_files in a platform dependent manner"""
+ if sys.platform.startswith('linux'):
+- if PY3:
+- data_files = [('share/applications', ['scripts/spyder3.desktop']),
+- ('share/icons', ['img_src/spyder3.png']),
+- ('share/metainfo', ['scripts/spyder3.appdata.xml'])]
+- else:
+- data_files = [('share/applications', ['scripts/spyder.desktop']),
++ data_files = [('share/applications', ['scripts/spyder.desktop']),
+ ('share/icons', ['img_src/spyder.png'])]
+ elif os.name == 'nt':
+ data_files = [('scripts', ['img_src/spyder.ico',
+@@ -112,21 +107,6 @@
+
+
+ #==============================================================================
+-# Make Linux detect Spyder desktop file
+-#==============================================================================
+-class MyInstallData(install_data):
+- def run(self):
+- install_data.run(self)
+- if sys.platform.startswith('linux'):
+- try:
+- subprocess.call(['update-desktop-database'])
+- except:
+- print("ERROR: unable to update desktop database",
+- file=sys.stderr)
+-CMDCLASS = {'install_data': MyInstallData}
+-
+-
+-#==============================================================================
+ # Main scripts
+ #==============================================================================
+ # NOTE: the '[...]_win_post_install.py' script is installed even on non-Windows
+@@ -210,8 +190,7 @@
+ 'Intended Audience :: Science/Research',
+ 'Intended Audience :: Developers',
+ 'Topic :: Scientific/Engineering',
+- 'Topic :: Software Development :: Widget Sets'],
+- cmdclass=CMDCLASS)
++ 'Topic :: Software Development :: Widget Sets'])
+
+
+ #==============================================================================