summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/spyder
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/spyder')
-rw-r--r--dev-python/spyder/Manifest2
-rw-r--r--dev-python/spyder/files/spyder-2.3.1-build.patch154
-rw-r--r--dev-python/spyder/metadata.xml30
-rw-r--r--dev-python/spyder/spyder-2.3.4.ebuild53
-rw-r--r--dev-python/spyder/spyder-2.3.5.2.ebuild51
5 files changed, 290 insertions, 0 deletions
diff --git a/dev-python/spyder/Manifest b/dev-python/spyder/Manifest
new file mode 100644
index 000000000000..3aad7ffffe69
--- /dev/null
+++ b/dev-python/spyder/Manifest
@@ -0,0 +1,2 @@
+DIST spyder-2.3.4.zip 3707063 SHA256 da4b13d6faed3e8810c0418f8274b26fde4f265ea4f93bee154af128a755c184 SHA512 7a4ea65ea06e9944094fc94db78327f9e23a8fd6dda5d0e9aa0e82ba4cd7d9f50b1eb837395a3fa2fabe814df873ad8ddbcca223144c47af4007b0493575e41e WHIRLPOOL 53e8f42bdafe01072457f27e45a279f92a198f181344f8267be2b3940cbd6d3743685ffe3264b04344f83bcb73b3eb8c9ec0e6bf8ccef26e19901324bfacb682
+DIST spyder-2.3.5.2.zip 3039104 SHA256 40e589467b561af534aac6d8cc2ea0dc244d3ae4457afb41b3aec6db6f8b2336 SHA512 ac8e078991b2889c3359e700bd89d4c8487eeba412512bc9bd7685214f687001bcc411016283bcde4eb73f6186ffc5cadc9614d911acd8b788899ef5aafd66e1 WHIRLPOOL e2b2bca44bd2ec1461875a358868ab34c60f30ac5164ff6312302b495e859000b97afc78ce12c69dbc328fdcbead247a9defce9e29c08de367fc7d3a321ff007
diff --git a/dev-python/spyder/files/spyder-2.3.1-build.patch b/dev-python/spyder/files/spyder-2.3.1-build.patch
new file mode 100644
index 000000000000..4300c3010bdd
--- /dev/null
+++ b/dev-python/spyder/files/spyder-2.3.1-build.patch
@@ -0,0 +1,154 @@
+--- setup.py
++++ setup.py
+@@ -21,8 +21,6 @@
+ import shutil
+
+ from distutils.core import setup
+-from distutils.command.build import build
+-from distutils.command.install_data import install_data
+
+ # Check for Python 3
+ PY3 = sys.version_info[0] == 3
+@@ -66,12 +64,7 @@
+ def get_data_files():
+ """Return data_files in a platform dependent manner"""
+ if sys.platform.startswith('linux'):
+- if PY3:
+- data_files = [('share/applications', ['scripts/spyder3.desktop']),
+- ('share/pixmaps', ['img_src/spyder3.png'])]
+- else:
+- data_files = [('share/applications', ['scripts/spyder.desktop']),
+- ('share/pixmaps', ['img_src/spyder.png'])]
++ data_files = [('share/pixmaps', ['img_src/spyder.png'])]
+ elif os.name == 'nt':
+ data_files = [('scripts', ['img_src/spyder.ico',
+ 'img_src/spyder_light.ico'])]
+@@ -80,97 +73,6 @@
+ return data_files
+
+
+-class MyInstallData(install_data):
+- def run(self):
+- install_data.run(self)
+- if sys.platform.startswith('linux'):
+- try:
+- subprocess.call(['update-desktop-database'])
+- except:
+- print("ERROR: unable to update desktop database",
+- file=sys.stderr)
+-CMDCLASS = {'install_data': MyInstallData}
+-
+-
+-# Sphinx build (documentation)
+-def get_html_help_exe():
+- """Return HTML Help Workshop executable path (Windows only)"""
+- if os.name == 'nt':
+- hhc_base = r'C:\Program Files%s\HTML Help Workshop\hhc.exe'
+- for hhc_exe in (hhc_base % '', hhc_base % ' (x86)'):
+- if osp.isfile(hhc_exe):
+- return hhc_exe
+- else:
+- return
+-
+-try:
+- from sphinx import setup_command
+-
+- class MyBuild(build):
+- user_options = [('no-doc', None, "Don't build Spyder documentation")] \
+- + build.user_options
+- def __init__(self, *args, **kwargs):
+- build.__init__(self, *args, **kwargs)
+- self.no_doc = False
+- def with_doc(self):
+- setup_dir = os.path.dirname(os.path.abspath(__file__))
+- is_doc_dir = os.path.isdir(os.path.join(setup_dir, 'doc'))
+- install_obj = self.distribution.get_command_obj('install')
+- return (is_doc_dir and not self.no_doc and not install_obj.no_doc)
+- sub_commands = build.sub_commands + [('build_doc', with_doc)]
+- CMDCLASS['build'] = MyBuild
+-
+-
+- class MyInstall(install):
+- user_options = [('no-doc', None, "Don't build Spyder documentation")] \
+- + install.user_options
+- def __init__(self, *args, **kwargs):
+- install.__init__(self, *args, **kwargs)
+- self.no_doc = False
+- CMDCLASS['install'] = MyInstall
+-
+-
+- class MyBuildDoc(setup_command.BuildDoc):
+- def run(self):
+- build = self.get_finalized_command('build')
+- sys.path.insert(0, os.path.abspath(build.build_lib))
+- dirname = self.distribution.get_command_obj('build').build_purelib
+- self.builder_target_dir = osp.join(dirname, 'spyderlib', 'doc')
+-
+- if not osp.exists(self.builder_target_dir):
+- os.mkdir(self.builder_target_dir)
+-
+- hhc_exe = get_html_help_exe()
+- self.builder = "html" if hhc_exe is None else "htmlhelp"
+-
+- try:
+- setup_command.BuildDoc.run(self)
+- except UnicodeDecodeError:
+- print("ERROR: unable to build documentation because Sphinx "\
+- "do not handle source path with non-ASCII characters. "\
+- "Please try to move the source package to another "\
+- "location (path with *only* ASCII characters).",
+- file=sys.stderr)
+- sys.path.pop(0)
+-
+- # Building chm doc, if HTML Help Workshop is installed
+- if hhc_exe is not None:
+- fname = osp.join(self.builder_target_dir, 'Spyderdoc.chm')
+- subprocess.call('"%s" %s' % (hhc_exe, fname), shell=True)
+- if osp.isfile(fname):
+- dest = osp.join(dirname, 'spyderlib')
+- try:
+- shutil.move(fname, dest)
+- except shutil.Error:
+- print("Unable to replace %s" % dest)
+- shutil.rmtree(self.builder_target_dir)
+-
+- CMDCLASS['build_doc'] = MyBuildDoc
+-except ImportError:
+- print('WARNING: unable to build documentation because Sphinx '\
+- 'is not installed', file=sys.stderr)
+-
+-
+ NAME = 'spyder'
+ LIBNAME = 'spyderlib'
+ from spyderlib import __version__, __project_url__
+@@ -204,13 +106,7 @@
+ packages = get_subpackages(LIBNAME)+get_subpackages('spyderplugins')
+ return packages
+
+-# NOTE: the '[...]_win_post_install.py' script is installed even on non-Windows
+-# platforms due to a bug in pip installation process (see Issue 1158)
+-SCRIPTS = ['%s_win_post_install.py' % NAME]
+-if PY3 and sys.platform.startswith('linux'):
+- SCRIPTS.append('spyder3')
+-else:
+- SCRIPTS.append('spyder')
++SCRIPTS = ['spyder']
+ EXTLIST = ['.mo', '.svg', '.png', '.css', '.html', '.js', '.chm', '.ini',
+ '.txt', '.rst']
+ if os.name == 'nt':
+@@ -246,7 +142,7 @@
+ package_data={LIBNAME: get_package_data(LIBNAME, EXTLIST),
+ 'spyderplugins':
+ get_package_data('spyderplugins', EXTLIST)},
+- requires=["rope (>=0.9.2)", "sphinx (>=0.6.0)", "PyQt4 (>=4.4)"],
++ requires=["rope (>=0.9.2)", "PyQt4 (>=4.4)"],
+ scripts=[osp.join('scripts', fname) for fname in SCRIPTS],
+ data_files=get_data_files(),
+ options={"bdist_wininst":
+@@ -267,5 +163,4 @@
+ 'Programming Language :: Python :: 3',
+ 'Development Status :: 5 - Production/Stable',
+ 'Topic :: Scientific/Engineering',
+- 'Topic :: Software Development :: Widget Sets'],
+- cmdclass=CMDCLASS)
++ 'Topic :: Software Development :: Widget Sets'])
diff --git a/dev-python/spyder/metadata.xml b/dev-python/spyder/metadata.xml
new file mode 100644
index 000000000000..c4364ce877cf
--- /dev/null
+++ b/dev-python/spyder/metadata.xml
@@ -0,0 +1,30 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>grozin@gentoo.org</email>
+ <name>Andrey Grozin</name>
+ </maintainer>
+ <longdescription lang="en">
+ Spyder development environment and its PyQt4-based IDE tools:
+ interactive Python shell, Python code editor, workspace
+ (dict/list/string/array editor), doc viewer, history log,
+ environment variables editor, ...
+</longdescription>
+ <use>
+ <flag name="ipython">Add support for <pkg>dev-python/ipython</pkg></flag>
+ <flag name="matplotlib">Add support for <pkg>dev-python/matplotlib</pkg></flag>
+ <flag name="numpy">Add support for <pkg>dev-python/numpy</pkg></flag>
+ <flag name="pep8">Add support for <pkg>dev-python/pep8</pkg></flag>
+ <flag name="pyflakes">Add support for <pkg>dev-python/pyflakes</pkg></flag>
+ <flag name="pylint">Add support for <pkg>dev-python/pylint</pkg></flag>
+ <flag name="rope">Add support for <pkg>dev-python/rope</pkg></flag>
+ <flag name="scipy">Add support for <pkg>sci-libs/scipy</pkg></flag>
+ <flag name="sphinx">Add support for <pkg>dev-python/sphinx</pkg></flag>
+ </use>
+ <upstream>
+ <remote-id type="pypi">spyder</remote-id>
+ <remote-id type="bitbucket">spyder-ide/spyderlib</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/spyder/spyder-2.3.4.ebuild b/dev-python/spyder/spyder-2.3.4.ebuild
new file mode 100644
index 000000000000..65b4f1a02fa9
--- /dev/null
+++ b/dev-python/spyder/spyder-2.3.4.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python IDE with matlab-like features"
+HOMEPAGE="http://code.google.com/p/spyderlib/ https://bitbucket.org/spyder-ide/spyderlib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc ipython matplotlib numpy pep8 +pyflakes pylint +rope scipy sphinx"
+
+# rope requires no version bordering since all are >= miniumum version
+RDEPEND="
+ || ( dev-python/PyQt4[${PYTHON_USEDEP},svg,webkit]
+ dev-python/pyside[${PYTHON_USEDEP},svg,webkit] )
+ ipython? ( dev-python/ipython[qt4,${PYTHON_USEDEP}] )
+ matplotlib? ( dev-python/matplotlib[${PYTHON_USEDEP}] )
+ numpy? ( dev-python/numpy[${PYTHON_USEDEP}] )
+ pep8? ( dev-python/pep8[${PYTHON_USEDEP}] )
+ pyflakes? ( >=dev-python/pyflakes-0.5[${PYTHON_USEDEP}] )
+ pylint? ( dev-python/pylint[${PYTHON_USEDEP}] )
+ rope? ( $(python_gen_cond_dep 'dev-python/rope[${PYTHON_USEDEP}]' python2_7) )
+ scipy? ( sci-libs/scipy[${PYTHON_USEDEP}] )
+ sphinx? ( >=dev-python/sphinx-0.6.0[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ doc? ( >=dev-python/sphinx-0.6.0[${PYTHON_USEDEP}] )"
+
+# Courtesy of Arfrever
+PATCHES=( "${FILESDIR}"/${PN}-2.3.1-build.patch )
+
+python_compile_all() {
+ if use doc; then
+ einfo "Generation of documentation"
+ PYTHONPATH="{BUILD_DIR}" \
+ sphinx-build doc doc/html || die "Generation of documentation failed"
+ fi
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doicon spyderlib/images/spyder.svg
+ make_desktop_entry spyder Spyder spyder "Development;IDE"
+ use doc && dohtml -r doc/html/
+}
diff --git a/dev-python/spyder/spyder-2.3.5.2.ebuild b/dev-python/spyder/spyder-2.3.5.2.ebuild
new file mode 100644
index 000000000000..405c654abdc8
--- /dev/null
+++ b/dev-python/spyder/spyder-2.3.5.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python IDE with matlab-like features"
+HOMEPAGE="http://code.google.com/p/spyderlib/ https://bitbucket.org/spyder-ide/spyderlib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc ipython matplotlib numpy pep8 +pyflakes pylint +rope scipy sphinx"
+
+# rope requires no version bordering since all are >= miniumum version
+RDEPEND="
+ || ( dev-python/PyQt4[${PYTHON_USEDEP},svg,webkit]
+ dev-python/pyside[${PYTHON_USEDEP},svg,webkit] )
+ ipython? ( dev-python/ipython[qt4,${PYTHON_USEDEP}] )
+ matplotlib? ( dev-python/matplotlib[${PYTHON_USEDEP}] )
+ numpy? ( dev-python/numpy[${PYTHON_USEDEP}] )
+ pep8? ( dev-python/pep8[${PYTHON_USEDEP}] )
+ pyflakes? ( >=dev-python/pyflakes-0.5[${PYTHON_USEDEP}] )
+ pylint? ( dev-python/pylint[${PYTHON_USEDEP}] )
+ rope? ( $(python_gen_cond_dep 'dev-python/rope[${PYTHON_USEDEP}]' python2_7) )
+ scipy? ( sci-libs/scipy[${PYTHON_USEDEP}] )
+ sphinx? ( >=dev-python/sphinx-0.6.0[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ doc? ( >=dev-python/sphinx-0.6.0[${PYTHON_USEDEP}] )"
+
+# Courtesy of Arfrever
+PATCHES=( "${FILESDIR}"/${PN}-2.3.1-build.patch )
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build doc doc/html || die "Generation of documentation failed"
+ fi
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doicon spyderlib/images/spyder.svg
+ make_desktop_entry spyder Spyder spyder "Development;IDE"
+ use doc && dodoc -r doc/html/
+}