summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-10 23:02:54 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-11 00:22:38 +0100
commit064af661d0c9a31cecdf348632bc5603333a9149 (patch)
tree2202373a7cafcb8a761d32747d4f62263aed64d5 /dev-python/sqlalchemy
parentdev-python/passlib: keyworded 1.7.1-r2 for hppa, bug #700918 (diff)
downloadgentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.gz
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.bz2
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.zip
*/*: [QA] Fix trivial cases of MissingTestRestrict
The result was achieved via the following pipeline: pkgcheck scan -c RestrictTestCheck -R FormatReporter \ --format '{category}/{package}/{package}-{version}.ebuild' | xargs -n32 grep -L RESTRICT | xargs -n32 sed -i -e '/^IUSE=.*test/aRESTRICT="!test? ( test )"' The resulting metadata was compared before and after the change. Few Go ebuilds had to be fixed manually due to implicit RESTRICT=strip added by the eclass. Two ebuilds have to be fixed because of multiline IUSE. Suggested-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13942 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sqlalchemy')
-rw-r--r--dev-python/sqlalchemy/sqlalchemy-0.7.10.ebuild3
-rw-r--r--dev-python/sqlalchemy/sqlalchemy-1.2.18.ebuild1
-rw-r--r--dev-python/sqlalchemy/sqlalchemy-1.3.3.ebuild1
-rw-r--r--dev-python/sqlalchemy/sqlalchemy-1.3.4.ebuild1
4 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/sqlalchemy/sqlalchemy-0.7.10.ebuild b/dev-python/sqlalchemy/sqlalchemy-0.7.10.ebuild
index 58d35ddc15f1..900e011459cf 100644
--- a/dev-python/sqlalchemy/sqlalchemy-0.7.10.ebuild
+++ b/dev-python/sqlalchemy/sqlalchemy-0.7.10.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -18,6 +18,7 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 arm hppa ia64 ~ppc ~ppc64 ~s390 ~sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
IUSE="doc examples mssql mysql postgres +sqlite test"
+RESTRICT="!test? ( test )"
RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
mssql? ( dev-python/pymssql )
diff --git a/dev-python/sqlalchemy/sqlalchemy-1.2.18.ebuild b/dev-python/sqlalchemy/sqlalchemy-1.2.18.ebuild
index 0983825757bc..02f3f4cba2a5 100644
--- a/dev-python/sqlalchemy/sqlalchemy-1.2.18.ebuild
+++ b/dev-python/sqlalchemy/sqlalchemy-1.2.18.ebuild
@@ -19,6 +19,7 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
IUSE="doc examples +sqlite test"
+RESTRICT="!test? ( test )"
REQUIRED_USE="test? ( sqlite )"
diff --git a/dev-python/sqlalchemy/sqlalchemy-1.3.3.ebuild b/dev-python/sqlalchemy/sqlalchemy-1.3.3.ebuild
index cbf891587597..1585d6c5e281 100644
--- a/dev-python/sqlalchemy/sqlalchemy-1.3.3.ebuild
+++ b/dev-python/sqlalchemy/sqlalchemy-1.3.3.ebuild
@@ -19,6 +19,7 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
IUSE="doc examples +sqlite test"
+RESTRICT="!test? ( test )"
REQUIRED_USE="test? ( sqlite )"
diff --git a/dev-python/sqlalchemy/sqlalchemy-1.3.4.ebuild b/dev-python/sqlalchemy/sqlalchemy-1.3.4.ebuild
index b26e2080f865..0759f412b978 100644
--- a/dev-python/sqlalchemy/sqlalchemy-1.3.4.ebuild
+++ b/dev-python/sqlalchemy/sqlalchemy-1.3.4.ebuild
@@ -19,6 +19,7 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
IUSE="doc examples +sqlite test"
+RESTRICT="!test? ( test )"
REQUIRED_USE="test? ( sqlite )"