summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/sqlite3dbm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/sqlite3dbm')
-rw-r--r--dev-python/sqlite3dbm/Manifest1
-rw-r--r--dev-python/sqlite3dbm/metadata.xml12
-rw-r--r--dev-python/sqlite3dbm/sqlite3dbm-0.1.4-r1.ebuild41
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/sqlite3dbm/Manifest b/dev-python/sqlite3dbm/Manifest
new file mode 100644
index 000000000000..012313d27b0c
--- /dev/null
+++ b/dev-python/sqlite3dbm/Manifest
@@ -0,0 +1 @@
+DIST sqlite3dbm-0.1.4-git.tar.gz 18962 SHA256 635cbf3f554c0cd75d68a6ebff57b2e29686bad1469a283a70f28ae8dd71c905 SHA512 1b420839482cf5881b744855393afa9eaa1cd0ea2195d03c6576f97804851dcfa5b5fe6a80d9d77eb00b9ee49ebb7cdb7ba7b86f57e4c700178a0bf46d598bab WHIRLPOOL 5e7789b042732edd8c4f3b06868582fff4164b4fa461d297f44ba2a3491a71b607f1b0b4b910e2edc1cddd1b86cc3c6a0bec482be7b36185d59d812a78ea7b8c
diff --git a/dev-python/sqlite3dbm/metadata.xml b/dev-python/sqlite3dbm/metadata.xml
new file mode 100644
index 000000000000..a461b42c335d
--- /dev/null
+++ b/dev-python/sqlite3dbm/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>idella4@gentoo.org</email>
+ <name>Ian Delaney</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Yelp/sqlite3dbm</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sqlite3dbm/sqlite3dbm-0.1.4-r1.ebuild b/dev-python/sqlite3dbm/sqlite3dbm-0.1.4-r1.ebuild
new file mode 100644
index 000000000000..9d56da483f0a
--- /dev/null
+++ b/dev-python/sqlite3dbm/sqlite3dbm-0.1.4-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+# TODO: strip the -git at some version bump, introduced to avoid clash with
+# earlier tarball
+DESCRIPTION="An sqlite-backed dictionary"
+HOMEPAGE="https://github.com/Yelp/sqlite3dbm http://pypi.python.org/pypi/sqlite3dbm/"
+SRC_URI="https://github.com/Yelp/${PN}/archive/v${PV}.tar.gz -> ${P}-git.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx )
+ test? ( dev-python/testify[${PYTHON_USEDEP}] )"
+
+DOCS=(AUTHORS.txt CHANGES.txt README.md)
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
+
+src_test() {
+ testify tests || die
+}