summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/sqlobject
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/sqlobject')
-rw-r--r--dev-python/sqlobject/Manifest1
-rw-r--r--dev-python/sqlobject/metadata.xml12
-rw-r--r--dev-python/sqlobject/sqlobject-2.1.1-r1.ebuild44
3 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/sqlobject/Manifest b/dev-python/sqlobject/Manifest
new file mode 100644
index 000000000000..b58c36de2a3a
--- /dev/null
+++ b/dev-python/sqlobject/Manifest
@@ -0,0 +1 @@
+DIST SQLObject-2.1.1.tar.gz 888532 SHA256 35675d9c6c5a373b68c1e597a51c2723e1a8471911f89b7ec9ab3cc380064874 SHA512 9f51452afb728b3eaa0b113aca7086af6cd858d3b6e84c557af56a086d9a04c7e061f1b45179d0c74ef6a175e593376e1ea3ce561a337d71df6eea0f7bd09fee WHIRLPOOL 0526d02b1815281724b1c5ad1fadf16a5dc3e765bb6c9e6b59db83e95a1f3bfa20134acad459e19583694739a38b3dece3bdc328ad7f57f09c95094759143a50
diff --git a/dev-python/sqlobject/metadata.xml b/dev-python/sqlobject/metadata.xml
new file mode 100644
index 000000000000..69b386336afc
--- /dev/null
+++ b/dev-python/sqlobject/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <longdescription>SQLObject is an object-relational mapper. It allows you to translate RDBMS table rows into Python objects and manipulate
+ those objects to transparently manipulate the database.</longdescription>
+ <longdescription lang="ja">SQLObject はオブジェクト・リレーショナル・マッパです。これはデータベースの操作を明瞭にするため、RDBMS のテーブル列を Python
+ 言語のオブジェクトとして操作できるようにします。</longdescription>
+ <upstream>
+ <remote-id type="pypi">SQLObject</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sqlobject/sqlobject-2.1.1-r1.ebuild b/dev-python/sqlobject/sqlobject-2.1.1-r1.ebuild
new file mode 100644
index 000000000000..6ec9266805a1
--- /dev/null
+++ b/dev-python/sqlobject/sqlobject-2.1.1-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite?"
+
+inherit distutils-r1
+
+MY_PN="SQLObject"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Object-Relational Manager, aka database wrapper"
+HOMEPAGE="http://sqlobject.org/ http://pypi.python.org/pypi/SQLObject"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc mysql postgres sqlite"
+
+RDEPEND="
+ >=dev-python/formencode-1.1.1[${PYTHON_USEDEP}]
+ mysql? ( dev-python/mysql-python[${PYTHON_USEDEP}] )
+ postgres? ( dev-python/psycopg[${PYTHON_USEDEP}] )"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ sed -e '/..docs/d' -i setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ if use doc; then
+ HTML_DOCS=( docs/html/. )
+ DOCS=( docs/europython/. )
+ fi
+
+ distutils-r1_python_install_all
+}