summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2019-04-07 09:46:08 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2019-04-07 09:47:16 -0400
commit72f70fcd542c933f0f411bddba9524bbe8d52bee (patch)
tree26f0d45e995e4dec575181e745a865c58bc3f982 /dev-python/sshtunnel/sshtunnel-0.1.4-r1.ebuild
parentvirtual/perl-Time-HiRes: Remove old (diff)
downloadgentoo-72f70fcd542c933f0f411bddba9524bbe8d52bee.tar.gz
gentoo-72f70fcd542c933f0f411bddba9524bbe8d52bee.tar.bz2
gentoo-72f70fcd542c933f0f411bddba9524bbe8d52bee.zip
dev-python/sshtunnel: Fix test invocation
Drop dev-python/tox requirement in favor of some direct dependencies on pytest, and no longer adds additional files to the image. Bug: https://bugs.gentoo.org/668146 Bug: https://bugs.gentoo.org/671484 Bug: https://bugs.gentoo.org/682260 Package-Manager: Portage-2.3.62, Repoman-2.3.11 Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
Diffstat (limited to 'dev-python/sshtunnel/sshtunnel-0.1.4-r1.ebuild')
-rw-r--r--dev-python/sshtunnel/sshtunnel-0.1.4-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/sshtunnel/sshtunnel-0.1.4-r1.ebuild b/dev-python/sshtunnel/sshtunnel-0.1.4-r1.ebuild
new file mode 100644
index 000000000000..38675ffce8b4
--- /dev/null
+++ b/dev-python/sshtunnel/sshtunnel-0.1.4-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure python SSH tunnels"
+HOMEPAGE="https://pypi.python.org/pypi/sshtunnel"
+SRC_URI="mirror://pypi/s/sshtunnel/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~arm ~x86"
+LICENSE="MIT"
+SLOT="0"
+
+IUSE="test"
+
+RDEPEND="dev-python/paramiko[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ py.test --showlocals --cov sshtunnel --durations=10 -n4 tests
+}