summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-30 13:50:05 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-30 14:09:32 +0100
commit909cac3a46771de997bae5dbbe027211c0032c5c (patch)
treede4b0b588e242aaa8f5a4e71f1b6a2764a292d42 /dev-python/ssl-fetch
parentdev-python/smartypants: Switch to PEP 517 build (diff)
downloadgentoo-909cac3a46771de997bae5dbbe027211c0032c5c.tar.gz
gentoo-909cac3a46771de997bae5dbbe027211c0032c5c.tar.bz2
gentoo-909cac3a46771de997bae5dbbe027211c0032c5c.zip
dev-python/ssl-fetch: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ssl-fetch')
-rw-r--r--dev-python/ssl-fetch/ssl-fetch-0.4-r1.ebuild29
-rw-r--r--dev-python/ssl-fetch/ssl-fetch-9999.ebuild9
2 files changed, 34 insertions, 4 deletions
diff --git a/dev-python/ssl-fetch/ssl-fetch-0.4-r1.ebuild b/dev-python/ssl-fetch/ssl-fetch-0.4-r1.ebuild
new file mode 100644
index 000000000000..9e9c925e0536
--- /dev/null
+++ b/dev-python/ssl-fetch/ssl-fetch-0.4-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Small convenience library for fetching files securely"
+HOMEPAGE="https://github.com/dol-sen/ssl-fetch"
+SRC_URI="https://dev.gentoo.org/~dolsen/releases/ssl-fetch/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~x64-macos"
+
+RDEPEND=">=dev-python/requests-1.2.1[${PYTHON_USEDEP}]"
+
+pkg_postinst() {
+ elog "This is beta software."
+ elog "The APIs it installs should be considered unstable"
+ elog "and are subject to change in these early versions."
+ elog
+ elog "Please file any enhancement requests, or bugs"
+ elog "at https://github.com/dol-sen/ssl-fetch/issues"
+ einfo "I am also on IRC @ #gentoo-ci of the Libera.Chat network"
+}
diff --git a/dev-python/ssl-fetch/ssl-fetch-9999.ebuild b/dev-python/ssl-fetch/ssl-fetch-9999.ebuild
index 74fea3ed7f27..ed96683472a6 100644
--- a/dev-python/ssl-fetch/ssl-fetch-9999.ebuild
+++ b/dev-python/ssl-fetch/ssl-fetch-9999.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
-PYTHON_COMPAT=( python3_{7,8,9} pypy3 )
-DISTUTILS_USE_SETUPTOOLS=no
inherit distutils-r1 git-r3
DESCRIPTION="Small convenience library for fetching files securely"