summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-07-25 01:58:40 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2018-07-25 02:06:59 -0500
commitd93f95f376040e7a939132ea701eaf874f86760d (patch)
tree909924adad441a13d7c9c0f0271a2b24ea689418 /dev-python/stestr/stestr-2.1.0.ebuild
parentdev-python/cliff: add missing keywords for stestr (diff)
downloadgentoo-d93f95f376040e7a939132ea701eaf874f86760d.tar.gz
gentoo-d93f95f376040e7a939132ea701eaf874f86760d.tar.bz2
gentoo-d93f95f376040e7a939132ea701eaf874f86760d.zip
dev-python/stestr: adding keywords for pbr
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'dev-python/stestr/stestr-2.1.0.ebuild')
-rw-r--r--dev-python/stestr/stestr-2.1.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/stestr/stestr-2.1.0.ebuild b/dev-python/stestr/stestr-2.1.0.ebuild
new file mode 100644
index 000000000000..372ba5486727
--- /dev/null
+++ b/dev-python/stestr/stestr-2.1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )
+inherit distutils-r1
+
+DESCRIPTION="A parallel Python test runner built around subunit"
+HOMEPAGE="https://github.com/mtreinish/stestr"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+#KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
+KEYWORDS="~amd64 ~arm64 ~hppa ~mips ~s390 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ dev-python/future[${PYTHON_USEDEP}]
+ >=dev-python/cliff-2.8.0[${PYTHON_USEDEP}]
+ >=dev-python/subunit-0.18.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10.0[${PYTHON_USEDEP}]
+ >=dev-python/voluptuous-0.8.9[${PYTHON_USEDEP}]"