summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-23 07:10:32 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-23 08:03:50 +0200
commit5d3d110efab47a09abff0d32ec86d0af54f0ffd5 (patch)
treec690291b80f418cc88c1ca1d07d09969d484516a /dev-python/stevedore/stevedore-2.0.1.ebuild
parentdev-python/sphinxcontrib-spelling: Bump to 5.1.2 (diff)
downloadgentoo-5d3d110efab47a09abff0d32ec86d0af54f0ffd5.tar.gz
gentoo-5d3d110efab47a09abff0d32ec86d0af54f0ffd5.tar.bz2
gentoo-5d3d110efab47a09abff0d32ec86d0af54f0ffd5.zip
dev-python/stevedore: Bump to 2.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/stevedore/stevedore-2.0.1.ebuild')
-rw-r--r--dev-python/stevedore/stevedore-2.0.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/stevedore/stevedore-2.0.1.ebuild b/dev-python/stevedore/stevedore-2.0.1.ebuild
new file mode 100644
index 000000000000..3b75793f9ca4
--- /dev/null
+++ b/dev-python/stevedore/stevedore-2.0.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Manage dynamic plugins for Python applications"
+HOMEPAGE="https://github.com/openstack/stevedore https://pypi.org/project/stevedore/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~hppa ~ia64 ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/testtools[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+distutils_enable_sphinx 'doc/source' \
+ '>=dev-python/openstackdocstheme-1.18.1' \
+ '>=dev-python/reno-2.5.0' \
+ '>=dev-python/sphinx-2.0.0'
+
+python_prepare_all() {
+ # Delete spurious data in requirements.txt
+ sed -e '/^pbr/d' -i requirements.txt || die
+ distutils-r1_python_prepare_all
+}