summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2016-04-24 10:14:06 -0500
committerAlex Brandt <alunduil@gentoo.org>2016-04-24 10:14:06 -0500
commit47b1828835e54f73ac4579909b32a71ee5e98a43 (patch)
tree41a22e46452f8bfacd91706e3fecdc81a8a8e38c /dev-python/stormpath/stormpath-2.3.1.ebuild
parentdev-python/wrapt: remove version 1.10.6 (diff)
downloadgentoo-47b1828835e54f73ac4579909b32a71ee5e98a43.tar.gz
gentoo-47b1828835e54f73ac4579909b32a71ee5e98a43.tar.bz2
gentoo-47b1828835e54f73ac4579909b32a71ee5e98a43.zip
dev-python/stormpath: add version 2.3.1
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python/stormpath/stormpath-2.3.1.ebuild')
-rw-r--r--dev-python/stormpath/stormpath-2.3.1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/stormpath/stormpath-2.3.1.ebuild b/dev-python/stormpath/stormpath-2.3.1.ebuild
new file mode 100644
index 000000000000..8248d4ff13f6
--- /dev/null
+++ b/dev-python/stormpath/stormpath-2.3.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Official Stormpath SDK, used to interact with the Stormpath REST API."
+HOMEPAGE="https://github.com/stormpath/stormpath-sdk-python"
+SRC_URI="https://github.com/stormpath/${PN}-sdk-python/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ >=dev-python/isodate-0.5.4[${PYTHON_USEDEP}]
+ >=dev-python/oauthlib-0.6.3[${PYTHON_USEDEP}]
+ >=dev-python/pydispatcher-2.0.5[${PYTHON_USEDEP}]
+ >=dev-python/pyjwt-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.4.3[${PYTHON_USEDEP}]
+ >=dev-python/six-1.6.1[${PYTHON_USEDEP}]
+"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}