summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-07 08:40:45 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-07 09:21:10 +0200
commiteb7b5f3225404a80c2a773ac9188b42d674a7e3e (patch)
treecf9dd288076cac31a5cf6310f149144c1d2b12c7 /dev-python/subprocess-tee/subprocess-tee-0.3.5.ebuild
parentdev-python/enrich: Enable py3.10 (diff)
downloadgentoo-eb7b5f3225404a80c2a773ac9188b42d674a7e3e.tar.gz
gentoo-eb7b5f3225404a80c2a773ac9188b42d674a7e3e.tar.bz2
gentoo-eb7b5f3225404a80c2a773ac9188b42d674a7e3e.zip
dev-python/subprocess-tee: Enable testing on py3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/subprocess-tee/subprocess-tee-0.3.5.ebuild')
-rw-r--r--dev-python/subprocess-tee/subprocess-tee-0.3.5.ebuild11
1 files changed, 1 insertions, 10 deletions
diff --git a/dev-python/subprocess-tee/subprocess-tee-0.3.5.ebuild b/dev-python/subprocess-tee/subprocess-tee-0.3.5.ebuild
index 80f643d83657..c715a596b1ae 100644
--- a/dev-python/subprocess-tee/subprocess-tee-0.3.5.ebuild
+++ b/dev-python/subprocess-tee/subprocess-tee-0.3.5.ebuild
@@ -14,28 +14,19 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
IUSE="test-full"
-
REQUIRED_USE="test-full? ( test )"
# ansible-molecule is invoked as an executable so no need for PYTHON_USEDEP
BDEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]
dev-python/setuptools_scm_git_archive[${PYTHON_USEDEP}]
test? (
- $(python_gen_cond_dep '
- dev-python/enrich[${PYTHON_USEDEP}]
- ' python3_{8,9})
+ dev-python/enrich[${PYTHON_USEDEP}]
test-full? ( app-admin/ansible-molecule )
)"
distutils_enable_tests pytest
-# dev-python/{,en}rich ebuilds do not support python3_10 yet.
-# We test fine (modulo some deprecation warnings) against 3.10 under tox, though.
python_test() {
- if [[ ${EPYTHON} == "python3.10" ]]; then
- ewarn "Skipping tests for ${EPYTHON} due to missing dependencies"
- return 0
- fi
if ! use test-full; then
local -x EPYTEST_DESELECT=( "src/${PN/-/_}/test/test_func.py::test_molecule" )
fi