summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2020-12-13 17:44:18 -0500
committerMike Gilbert <floppym@gentoo.org>2020-12-13 17:44:40 -0500
commit5f92e68f84de5ab7081731758d40c58f7effce9a (patch)
treecf84a10f8564306677532962f27a9054af401b3d /dev-python/subunit/subunit-1.4.0.ebuild
parentdev-python/subunit: remove -Werror from configure.ac (diff)
downloadgentoo-5f92e68f84de5ab7081731758d40c58f7effce9a.tar.gz
gentoo-5f92e68f84de5ab7081731758d40c58f7effce9a.tar.bz2
gentoo-5f92e68f84de5ab7081731758d40c58f7effce9a.zip
dev-python/subunit: call eautoreconf before multilib_copy_sources
Also clean up the werror patch. Bug: https://bugs.gentoo.org/744313 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'dev-python/subunit/subunit-1.4.0.ebuild')
-rw-r--r--dev-python/subunit/subunit-1.4.0.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-python/subunit/subunit-1.4.0.ebuild b/dev-python/subunit/subunit-1.4.0.ebuild
index 39cfb5fff590..9962579f395e 100644
--- a/dev-python/subunit/subunit-1.4.0.ebuild
+++ b/dev-python/subunit/subunit-1.4.0.ebuild
@@ -34,7 +34,9 @@ DEPEND="
dev-python/testscenarios[${PYTHON_USEDEP}]
)"
-PATCHES=( "${FILESDIR}/${P}-werror.patch" )
+PATCHES=(
+ "${FILESDIR}/subunit-1.4.0-werror.patch"
+)
src_prepare() {
sed -i -e 's/os.chdir(os.path.dirname(__file__))//' setup.py || die
@@ -47,8 +49,8 @@ src_prepare() {
python/subunit/tests/test_subunit_tags.py || die
distutils-r1_src_prepare
- multilib_copy_sources
eautoreconf
+ multilib_copy_sources
}
multilib_src_configure() {