summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-10-14 01:03:10 +0200
committerMichał Górny <mgorny@gentoo.org>2015-10-14 08:06:35 +0200
commit5b6edb4a3b74a81ee8d238aaabe59b8d8ff8246f (patch)
treef2de3644b75e298ceeaed790daab2aa73e57d62f /dev-python/subunit
parentdev-python/setuptools: Partially restore ~arch keywords (diff)
downloadgentoo-5b6edb4a3b74a81ee8d238aaabe59b8d8ff8246f.tar.gz
gentoo-5b6edb4a3b74a81ee8d238aaabe59b8d8ff8246f.tar.bz2
gentoo-5b6edb4a3b74a81ee8d238aaabe59b8d8ff8246f.zip
dev-python/*: Restore keywords and un-revbump for py3.5
Restore keywords that were removed unnecessarily, and collapse unnecessary revbumps on packages with added python3.5 support.
Diffstat (limited to 'dev-python/subunit')
-rw-r--r--dev-python/subunit/subunit-1.1.0-r1.ebuild90
-rw-r--r--dev-python/subunit/subunit-1.1.0.ebuild2
2 files changed, 1 insertions, 91 deletions
diff --git a/dev-python/subunit/subunit-1.1.0-r1.ebuild b/dev-python/subunit/subunit-1.1.0-r1.ebuild
deleted file mode 100644
index 96db9ac6c7d0..000000000000
--- a/dev-python/subunit/subunit-1.1.0-r1.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
-
-inherit distutils-r1 eutils multilib-minimal
-
-DESCRIPTION="A streaming protocol for test results"
-HOMEPAGE="https://launchpad.net/subunit https://pypi.python.org/pypi/python-subunit"
-SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
-
-LICENSE="Apache-2.0 BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~x86-fbsd"
-IUSE="static-libs test"
-
-RDEPEND="
- >=dev-python/testtools-0.9.34[${PYTHON_USEDEP}]
- dev-python/extras[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-lang/perl:=
- >=dev-libs/check-0.9.11[${MULTILIB_USEDEP}]
- >=dev-util/cppunit-1.13.2[${MULTILIB_USEDEP}]
- >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
- test? ( dev-python/testscenarios[${PYTHON_USEDEP}] )"
-
-# Take out rogue & trivial failing tests that exit the suite before it even gets started
-# The removed class in fact works fine in py3 and fails with py2.7 & pupu
-# The setu to restrict this patch is just those 2 is not worth it.
-PATCHES=( "${FILESDIR}"/1.0.0-tests.patch )
-
-src_prepare() {
- sed -i -e 's/os.chdir(os.path.dirname(__file__))//' setup.py || die
-
- # Install perl modules in vendor_perl, bug 534654.
- export INSTALLDIRS=vendor
-
- # needed for perl modules
- distutils-r1_src_prepare
- multilib_copy_sources
-}
-
-multilib_src_configure() {
- ECONF_SOURCE=${S} \
- econf \
- --enable-shared \
- $(use_enable static-libs static)
-}
-
-multilib_src_compile() {
- default
- multilib_is_native_abi && distutils-r1_src_compile
-}
-
-python_test() {
- local -x PATH="${PWD}/shell/share:${PATH}"
- local -x PYTHONPATH=python
- # Following tests are known to fail in py2.7 & pypy. They pass under py3.
- # DO NOT re-file
- # test_add_error test_add_error_details test_add_expected_failure
- # test_add_expected_failure_details test_add_failure test_add_failure
- # https://bugs.launchpad.net/subunit/+bug/1436686
-
- "${PYTHON}" -m testtools.run all_tests.test_suite || die "Testing failed with ${EPYTHON}"
-}
-
-multilib_src_test() {
- multilib_is_native_abi && distutils-r1_src_test
-}
-
-multilib_src_install() {
- local targets=(
- install-include_subunitHEADERS
- install-pcdataDATA
- install-exec-local
- install-libLTLIBRARIES
- )
- emake DESTDIR="${D}" "${targets[@]}"
-
- multilib_is_native_abi && distutils-r1_src_install
-}
-
-multilib_src_install_all() {
- einstalldocs
- prune_libtool_files
-}
diff --git a/dev-python/subunit/subunit-1.1.0.ebuild b/dev-python/subunit/subunit-1.1.0.ebuild
index 22bac6e196d1..30b3b69a7107 100644
--- a/dev-python/subunit/subunit-1.1.0.ebuild
+++ b/dev-python/subunit/subunit-1.1.0.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
inherit distutils-r1 eutils multilib-minimal