summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-14 09:59:30 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-14 10:25:53 +0200
commit5cc6ec2b6f9890dd9b93a7905504bc4819a9f91b (patch)
tree5fa2ffa225cfb957ffa71677d6ab3fbb109a63cc /dev-python/sure
parentdev-python/python-bugzilla: Enable py3.11 (diff)
downloadgentoo-5cc6ec2b6f9890dd9b93a7905504bc4819a9f91b.tar.gz
gentoo-5cc6ec2b6f9890dd9b93a7905504bc4819a9f91b.tar.bz2
gentoo-5cc6ec2b6f9890dd9b93a7905504bc4819a9f91b.zip
dev-python/sure: Use PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sure')
-rw-r--r--dev-python/sure/sure-2.0.0-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/sure/sure-2.0.0-r1.ebuild b/dev-python/sure/sure-2.0.0-r1.ebuild
new file mode 100644
index 000000000000..fc548d3074ac
--- /dev/null
+++ b/dev-python/sure/sure-2.0.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="idiomatic assertion toolkit with human-friendly failure messages"
+HOMEPAGE="
+ https://github.com/gabrielfalcao/sure/
+ https://pypi.org/project/sure/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # requires dev-python/nose
+ tests/test_old_api.py
+)
+
+src_prepare() {
+ sed -i -e 's:--cov=sure::' setup.cfg || die
+ distutils-r1_src_prepare
+}