summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-03-21 22:08:14 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-03-21 22:39:46 +0200
commitd824ba59c96806ec4e93eb642903262c5a11fa4a (patch)
treec8d52ffa14641094d6570e1316c32d48dc9b5c8d /dev-python/svg-path/svg-path-5.0.1.ebuild
parentmedia-libs/kimageannotator: Stabilize 0.5.3 amd64, #828017 (diff)
downloadgentoo-d824ba59c96806ec4e93eb642903262c5a11fa4a.tar.gz
gentoo-d824ba59c96806ec4e93eb642903262c5a11fa4a.tar.bz2
gentoo-d824ba59c96806ec4e93eb642903262c5a11fa4a.zip
dev-python/svg-path: add 5.0.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/svg-path/svg-path-5.0.1.ebuild')
-rw-r--r--dev-python/svg-path/svg-path-5.0.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/svg-path/svg-path-5.0.1.ebuild b/dev-python/svg-path/svg-path-5.0.1.ebuild
new file mode 100644
index 000000000000..c4dc52ae51aa
--- /dev/null
+++ b/dev-python/svg-path/svg-path-5.0.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_P="svg.path-${PV}"
+DESCRIPTION="SVG path objects and parser"
+HOMEPAGE="https://github.com/regebro/svg.path"
+SRC_URI="
+ https://github.com/regebro/svg.path/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ src/svg/path/tests/test_image.py::ImageTest::test_image
+)