summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-11-04 07:53:57 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2021-11-04 08:03:35 +0200
commitd88b542562009ef90a5a213d7962ac501eb32c5b (patch)
tree810f4a916f1c40ecfc822eb87accd878f180cff2 /dev-python/svglib
parentdev-ruby/httpauth: add ruby30 (diff)
downloadgentoo-d88b542562009ef90a5a213d7962ac501eb32c5b.tar.gz
gentoo-d88b542562009ef90a5a213d7962ac501eb32c5b.tar.bz2
gentoo-d88b542562009ef90a5a213d7962ac501eb32c5b.zip
dev-python/svglib: new dep for dev-python/easy-thumbnails
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/svglib')
-rw-r--r--dev-python/svglib/Manifest1
-rw-r--r--dev-python/svglib/metadata.xml13
-rw-r--r--dev-python/svglib/svglib-1.1.0.ebuild33
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/svglib/Manifest b/dev-python/svglib/Manifest
new file mode 100644
index 000000000000..dc36967f9a98
--- /dev/null
+++ b/dev-python/svglib/Manifest
@@ -0,0 +1 @@
+DIST svglib-1.1.0.gh.tar.gz 2403896 BLAKE2B f3f45c526897cb64c44ab3dfb314d61faf190d482e0ce7c255ca51a45c2944393ac7ed0f83c9721648885ae7e477b87bf40040a01641c54ca31dcf85f97bf0fd SHA512 cc4eed96f021e9399e1a25bc477bdc91c037393b492ecd1eabb31c1163c8374499bc50b63ca60b038c61c7a799f4131183464f6799077875dd73a4e97a1246cf
diff --git a/dev-python/svglib/metadata.xml b/dev-python/svglib/metadata.xml
new file mode 100644
index 000000000000..c4da9c1eef1d
--- /dev/null
+++ b/dev-python/svglib/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">svglib</remote-id>
+ <remote-id type="github">deeplook/svglib</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/svglib/svglib-1.1.0.ebuild b/dev-python/svglib/svglib-1.1.0.ebuild
new file mode 100644
index 000000000000..fbcf162cb4cc
--- /dev/null
+++ b/dev-python/svglib/svglib-1.1.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Pure-Python library for reading and converting SVG"
+HOMEPAGE="https://pypi.org/project/svglib/ https://github.com/deeplook/svglib"
+SRC_URI="
+ https://github.com/deeplook/svglib/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/cssselect2[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/reportlab[${PYTHON_USEDEP}]
+ dev-python/tinycss2[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Needs network access
+ tests/test_samples.py::TestWikipediaFlags::test_convert_pdf
+ tests/test_samples.py::TestW3CSVG::test_convert_pdf_png
+)