summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2018-07-11 23:29:01 +0200
committerJason A. Donenfeld <zx2c4@gentoo.org>2018-07-11 23:35:25 +0200
commit4fa384ee9394fdc66c99208ce37798d0c4094a4d (patch)
treebfdb4528a10040e932baaf43653acfa365637d68 /dev-python/svgwrite/svgwrite-1.1.12.ebuild
parentapp-shells/zsh: stable 5.5.1-r1 for sparc (diff)
downloadgentoo-4fa384ee9394fdc66c99208ce37798d0c4094a4d.tar.gz
gentoo-4fa384ee9394fdc66c99208ce37798d0c4094a4d.tar.bz2
gentoo-4fa384ee9394fdc66c99208ce37798d0c4094a4d.zip
dev-python/svgwrite: import new ebuild
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'dev-python/svgwrite/svgwrite-1.1.12.ebuild')
-rw-r--r--dev-python/svgwrite/svgwrite-1.1.12.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/svgwrite/svgwrite-1.1.12.ebuild b/dev-python/svgwrite/svgwrite-1.1.12.ebuild
new file mode 100644
index 000000000000..dde90e114ee0
--- /dev/null
+++ b/dev-python/svgwrite/svgwrite-1.1.12.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+inherit distutils-r1
+
+DESCRIPTION="Python Package to write SVG files"
+HOMEPAGE="https://github.com/mozman/svgwrite"
+SRC_URI="https://github.com/mozman/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-python/pyparsing-2.0.1[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"