summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-15 19:32:20 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-15 19:34:29 +0100
commit485394b6ebe2f3d83ad39388f2f07cb590d4670f (patch)
tree28a52da8af4b6023a69419f61a2e09330d8d1313 /dev-python/svgwrite/svgwrite-1.4.1.ebuild
parentdev-python/python-utils: Remove 2.5.0 (diff)
downloadgentoo-485394b6ebe2f3d83ad39388f2f07cb590d4670f.tar.gz
gentoo-485394b6ebe2f3d83ad39388f2f07cb590d4670f.tar.bz2
gentoo-485394b6ebe2f3d83ad39388f2f07cb590d4670f.zip
dev-python/svgwrite: Bump to 1.4.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/svgwrite/svgwrite-1.4.1.ebuild')
-rw-r--r--dev-python/svgwrite/svgwrite-1.4.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/svgwrite/svgwrite-1.4.1.ebuild b/dev-python/svgwrite/svgwrite-1.4.1.ebuild
new file mode 100644
index 000000000000..c4b91842d3ae
--- /dev/null
+++ b/dev-python/svgwrite/svgwrite-1.4.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Python Package to write SVG files"
+HOMEPAGE="https://github.com/mozman/svgwrite"
+SRC_URI="https://github.com/mozman/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # fetches from the Internet
+ sed -i -e 's:test_embed_google_web_font:_&:' \
+ tests/test_style.py || die
+ distutils-r1_src_prepare
+}