summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-28 07:19:06 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-28 09:00:29 +0200
commit479fece57e01e18cb98af01545a4bf2d299cfe5a (patch)
tree755cf60bdd23c4fcb698a09282058dedc2272fe3 /dev-python/sybil
parentnet-firewall/nftables: x86 stable wrt bug #820554 (diff)
downloadgentoo-479fece57e01e18cb98af01545a4bf2d299cfe5a.tar.gz
gentoo-479fece57e01e18cb98af01545a4bf2d299cfe5a.tar.bz2
gentoo-479fece57e01e18cb98af01545a4bf2d299cfe5a.zip
dev-python/sybil: Bump to 3.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sybil')
-rw-r--r--dev-python/sybil/Manifest1
-rw-r--r--dev-python/sybil/files/sybil-3.0.0-test-order.patch45
-rw-r--r--dev-python/sybil/metadata.xml2
-rw-r--r--dev-python/sybil/sybil-3.0.0.ebuild21
4 files changed, 68 insertions, 1 deletions
diff --git a/dev-python/sybil/Manifest b/dev-python/sybil/Manifest
index c7aaeb7e1830..d344d3574395 100644
--- a/dev-python/sybil/Manifest
+++ b/dev-python/sybil/Manifest
@@ -1 +1,2 @@
DIST sybil-2.0.1.tar.gz 29316 BLAKE2B cf03bc1595efab535d1248b9d267dcd01547f02539977c12b8753e70d13ea0744a6ab76dc1e44fd1c46d192577aa4c1a9b5d5d52678928acfd63937358fa3e33 SHA512 4f3be7686c1acf6812623a756fa79b41e3fbe5d4c3b4c7cf5dfe39fbe56806b4ef3acd24e25968ab9119b2c65ad5c30eabe32f1a93fb62ba8d3893ef123e69f0
+DIST sybil-3.0.0.tar.gz 38011 BLAKE2B 7a42d5b0f3f13ac111d9edc9f74cb4d968f49680bb33d267ee762e830b134fa8c2e1697834d6a6a7aa09c9cd1dc52552379ca43e6667ee844f54f34b8bd3ffc7 SHA512 b6f5b5ebdeeab2ecbe17b6f83f0bc7e83e68f8e784b6a0eea292020db42294f8a1d0288d208f8a5803d5866038c3226f0b7d0d177c91469c4651364078d1bb4d
diff --git a/dev-python/sybil/files/sybil-3.0.0-test-order.patch b/dev-python/sybil/files/sybil-3.0.0-test-order.patch
new file mode 100644
index 000000000000..1badf5b06a19
--- /dev/null
+++ b/dev-python/sybil/files/sybil-3.0.0-test-order.patch
@@ -0,0 +1,45 @@
+From 4d1e1c891bd619a0dec0a265a930bf49050833d1 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Wed, 27 Oct 2021 13:07:01 +0200
+Subject: [PATCH] Restore sorting of test paths to make tests reliable again
+
+11496eb5761761b687ad4889b4173d3124caa844 has replaced the all_documents
+method with a direct call to glob. This has implicitly resulted
+in removal of path sorting that in turn means that the test output
+depends on filesystem order now and is no longer reliable.
+In particular, the tests can now fail randomly depending
+on the underlying filesystem, unpack/checkout order, etc. Restore
+explicit sorting to make test order predictable again.
+
+Fixes #34
+---
+ sybil/integration/unittest.py | 2 +-
+ tests/test_sybil.py | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/sybil/integration/unittest.py b/sybil/integration/unittest.py
+index 7129ddf..ce34caf 100644
+--- a/sybil/integration/unittest.py
++++ b/sybil/integration/unittest.py
+@@ -38,7 +38,7 @@ def unittest_integration(sybil: 'Sybil'):
+
+ def load_tests(loader=None, tests=None, pattern=None):
+ suite = TestSuite()
+- for path in sybil.path.glob('**/*'):
++ for path in sorted(sybil.path.glob('**/*')):
+ if path.is_file() and sybil.should_parse(path):
+ document = sybil.parse(path)
+
+diff --git a/tests/test_sybil.py b/tests/test_sybil.py
+index 74a04ea..72a5aea 100644
+--- a/tests/test_sybil.py
++++ b/tests/test_sybil.py
+@@ -243,7 +243,7 @@ def parse(document):
+
+ def test_namespace(capsys):
+ sybil = Sybil([parse], path='./samples')
+- documents = [sybil.parse(p) for p in sybil.path.glob('sample*.txt')]
++ documents = [sybil.parse(p) for p in sorted(sybil.path.glob('sample*.txt'))]
+ actual = []
+ for document in documents:
+ for example in document:
diff --git a/dev-python/sybil/metadata.xml b/dev-python/sybil/metadata.xml
index 24dad470d827..aba09c672231 100644
--- a/dev-python/sybil/metadata.xml
+++ b/dev-python/sybil/metadata.xml
@@ -8,6 +8,6 @@
<stabilize-allarches/>
<upstream>
<remote-id type="pypi">sybil</remote-id>
- <remote-id type="github">cjw296/sybil</remote-id>
+ <remote-id type="github">simplistix/sybil</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-python/sybil/sybil-3.0.0.ebuild b/dev-python/sybil/sybil-3.0.0.ebuild
new file mode 100644
index 000000000000..5ac40aac71ef
--- /dev/null
+++ b/dev-python/sybil/sybil-3.0.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Automated testing for the examples in your documentation"
+HOMEPAGE="https://github.com/simplistix/sybil"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}"/${P}-test-order.patch
+)