summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-12-14 20:50:10 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-12-14 20:52:31 +0100
commit9a381c100af67473b243394aef2f65451e411e5c (patch)
treeb6ea63a0bf6815d3ccc21553c549003f4d898ddb /dev-python/symengine/symengine-0.8.1.ebuild
parentsci-libs/symengine: add version 0.8.1 (diff)
downloadgentoo-9a381c100af67473b243394aef2f65451e411e5c.tar.gz
gentoo-9a381c100af67473b243394aef2f65451e411e5c.tar.bz2
gentoo-9a381c100af67473b243394aef2f65451e411e5c.zip
dev-python/symengine: add version 0.8.1
Need py3.10 on sympy --> pyglet --> gst-python to add py3.10 here Bug: https://bugs.gentoo.org/812194 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/symengine/symengine-0.8.1.ebuild')
-rw-r--r--dev-python/symengine/symengine-0.8.1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/symengine/symengine-0.8.1.ebuild b/dev-python/symengine/symengine-0.8.1.ebuild
new file mode 100644
index 000000000000..0d794b6c2980
--- /dev/null
+++ b/dev-python/symengine/symengine-0.8.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+MY_P=${PN}.py-${PV}
+DESCRIPTION="Python wrappers to the symengine C++ library"
+HOMEPAGE="https://github.com/symengine/symengine.py/"
+SRC_URI="
+ https://github.com/symengine/symengine.py/archive/v${PV}.tar.gz
+ -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ dev-util/cmake
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/sympy[${PYTHON_USEDEP}]
+ )
+"
+# See bug #786582 for symengine constraint
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=sci-libs/symengine-$(ver_cut 1-2)
+"
+
+distutils_enable_tests pytest
+
+# the C library installs the same docs
+DOCS=()
+
+src_prepare() {
+ default
+
+ # Don't install tests
+ > "${S}/symengine/tests/CMakeLists.txt" || die
+}
+
+python_test() {
+ cd "${BUILD_DIR}" || die
+ epytest
+}
+
+python_install() {
+ distutils-r1_python_install
+ python_optimize
+}