summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-07 08:27:02 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-07 13:49:11 +0200
commitbe6e69f8c513d22497461ab11e7b29f2e34c9a55 (patch)
treecebf5ec31908243e0f9e39e6b57b0de45745c872 /dev-python/tabulate/tabulate-0.8.3.ebuild
parentmedia-sound/guitarix: use array to pass configure args (diff)
downloadgentoo-be6e69f8c513d22497461ab11e7b29f2e34c9a55.tar.gz
gentoo-be6e69f8c513d22497461ab11e7b29f2e34c9a55.tar.bz2
gentoo-be6e69f8c513d22497461ab11e7b29f2e34c9a55.zip
dev-python/tabulate: Bump to 0.8.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tabulate/tabulate-0.8.3.ebuild')
-rw-r--r--dev-python/tabulate/tabulate-0.8.3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/tabulate/tabulate-0.8.3.ebuild b/dev-python/tabulate/tabulate-0.8.3.ebuild
new file mode 100644
index 000000000000..47d173efc49a
--- /dev/null
+++ b/dev-python/tabulate/tabulate-0.8.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pretty-print tabular data"
+HOMEPAGE="https://pypi.org/project/tabulate/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/wcwidth[${PYTHON_USEDEP}]"
+# TODO: optional test-dep on colorclass
+DEPEND="
+ test? (
+ ${RDEPEND}
+ $(python_gen_impl_dep 'sqlite')
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ virtual/python-funcsigs[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ esetup.py test
+}