summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-23 11:16:14 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-23 11:20:09 +0200
commit47f635b3de9132d45df3af19969bdd31361e87bd (patch)
treee63302b1cba94ff53c8f7bec6542ce7228ebd8b9 /dev-python/tabulate
parentdev-python/colorclass: Enable py3.11 (diff)
downloadgentoo-47f635b3de9132d45df3af19969bdd31361e87bd.tar.gz
gentoo-47f635b3de9132d45df3af19969bdd31361e87bd.tar.bz2
gentoo-47f635b3de9132d45df3af19969bdd31361e87bd.zip
dev-python/tabulate: Use PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tabulate')
-rw-r--r--dev-python/tabulate/Manifest1
-rw-r--r--dev-python/tabulate/tabulate-0.8.9-r1.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/tabulate/Manifest b/dev-python/tabulate/Manifest
index 5827c1aa41c3..20a87b21dcf0 100644
--- a/dev-python/tabulate/Manifest
+++ b/dev-python/tabulate/Manifest
@@ -1 +1,2 @@
+DIST python-tabulate-0.8.9.gh.tar.gz 42562 BLAKE2B 6e6e1017379d07d5ede0cdfb6a8e3142f60656fd5d5b409c1259239e62637824c3bab0bb0f6b03f8733a24e9e3ac074a80a56d44939a8c6eeab8e9a830ae8277 SHA512 68a4d194068f692b57b2cca0fa42a58ba571b46adaef7f8b1a8cea7e34c78ea0a1c523286c3f1df631897cc60ad39ef6b11bfee61d46c04e2de1fb9ec0b497dd
DIST tabulate-0.8.9.tar.gz 42562 BLAKE2B 6e6e1017379d07d5ede0cdfb6a8e3142f60656fd5d5b409c1259239e62637824c3bab0bb0f6b03f8733a24e9e3ac074a80a56d44939a8c6eeab8e9a830ae8277 SHA512 68a4d194068f692b57b2cca0fa42a58ba571b46adaef7f8b1a8cea7e34c78ea0a1c523286c3f1df631897cc60ad39ef6b11bfee61d46c04e2de1fb9ec0b497dd
diff --git a/dev-python/tabulate/tabulate-0.8.9-r1.ebuild b/dev-python/tabulate/tabulate-0.8.9-r1.ebuild
new file mode 100644
index 000000000000..9086aec4df76
--- /dev/null
+++ b/dev-python/tabulate/tabulate-0.8.9-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+MY_P=python-${P}
+DESCRIPTION="Pretty-print tabular data"
+HOMEPAGE="
+ https://github.com/astanin/python-tabulate/
+ https://pypi.org/project/tabulate/
+"
+SRC_URI="
+ https://github.com/astanin/python-${PN}/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep 'sqlite')
+ dev-python/colorclass[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/numpy[${PYTHON_USEDEP}]
+ ' 'python3*')
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=()
+ if ! has_version "dev-python/pandas[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ test/test_input.py::test_pandas
+ test/test_input.py::test_pandas_firstrow
+ test/test_input.py::test_pandas_keys
+ test/test_output.py::test_pandas_with_index
+ test/test_output.py::test_pandas_without_index
+ test/test_output.py::test_pandas_rst_with_index
+ test/test_output.py::test_pandas_rst_with_named_index
+ )
+ fi
+ epytest
+}