summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2017-11-07 10:49:46 -0800
committerZac Medico <zmedico@gentoo.org>2017-11-07 11:03:02 -0800
commitfaf200a2246623dbba5eb2d805df8c03818a719c (patch)
tree7e49fc3e7bd3b41accfc17c20f1622997ae8bf81 /dev-python/tabulate
parentdev-python/clang-python: Enable python3 (diff)
downloadgentoo-faf200a2246623dbba5eb2d805df8c03818a719c.tar.gz
gentoo-faf200a2246623dbba5eb2d805df8c03818a719c.tar.bz2
gentoo-faf200a2246623dbba5eb2d805df8c03818a719c.zip
dev-python/tabulate: version bump to 0.8.1
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'dev-python/tabulate')
-rw-r--r--dev-python/tabulate/Manifest1
-rw-r--r--dev-python/tabulate/tabulate-0.8.1.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/tabulate/Manifest b/dev-python/tabulate/Manifest
index af0bd3f52256..cf55c561b076 100644
--- a/dev-python/tabulate/Manifest
+++ b/dev-python/tabulate/Manifest
@@ -1 +1,2 @@
DIST tabulate-0.7.7.tar.gz 39140 SHA256 83a0b8e17c09f012090a50e1e97ae897300a72b35e0c86c0b53d3bd2ae86d8c6 SHA512 36ea77577e36fad28efa9b1c10686a4a795acdea77be4f8b442b38f45d70993245b4b473b0ce146f3d24eb49f186ec47ada332a9a3973ac2786d5a46b7358213 WHIRLPOOL 7d64e01b9a2d4ed41733b67e4108e233ba97ca95029f4f82c1b73f489dd0e17589cfbe071fd83969422779e73eb7fc1e5b7d48c891b3dcd647a9d4266900a462
+DIST tabulate-0.8.1.tar.gz 45666 SHA256 b9b4d2fc712c1e3b8f2970edf6d83fd8a329d0148de78bbe2755a79a96c190fa SHA512 f724fbabee53c738c846a5cf645470f5f97074e2b33eb030b4859478931661dac53e5446d77a656553e2dec323230bb116d350997e1407d794382f537e6dfdf5 WHIRLPOOL 53f1324078a4971720a27d66d97ffef96a514a0ae229007c1d9893b0b4cb8424a1256e3cae23ed3ee41bb8f6dd58115d50b8e24de0d351f89306b967002afe99
diff --git a/dev-python/tabulate/tabulate-0.8.1.ebuild b/dev-python/tabulate/tabulate-0.8.1.ebuild
new file mode 100644
index 000000000000..a91800179602
--- /dev/null
+++ b/dev-python/tabulate/tabulate-0.8.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pretty-print tabular data"
+HOMEPAGE="https://pypi.python.org/pypi/tabulate"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ test? ( virtual/python-funcsigs[${PYTHON_USEDEP}] )
+"
+
+# Missing something in tarball
+#
+# from common import assert_equal
+RESTRICT=test
+
+python_test() {
+ local testcase
+ for testcase in test/*py; do
+ ${PYTHON} ${testcase} || die
+ done
+}