summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-19 23:22:07 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-19 23:59:36 +0100
commit5a44d5eee3ef821fcdb90560651647ca50f71d82 (patch)
tree455c92dc9c0c1c5adb99fafbd42c41947302a2ea /dev-python/tekore
parentdev-python/dogpile-cache: Bump to 1.1.5 (diff)
downloadgentoo-5a44d5eee3ef821fcdb90560651647ca50f71d82.tar.gz
gentoo-5a44d5eee3ef821fcdb90560651647ca50f71d82.tar.bz2
gentoo-5a44d5eee3ef821fcdb90560651647ca50f71d82.zip
dev-python/tekore: Bump to 4.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tekore')
-rw-r--r--dev-python/tekore/Manifest1
-rw-r--r--dev-python/tekore/tekore-4.2.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/tekore/Manifest b/dev-python/tekore/Manifest
index bfa85b5e9031..6984225cd2a9 100644
--- a/dev-python/tekore/Manifest
+++ b/dev-python/tekore/Manifest
@@ -1,2 +1,3 @@
DIST tekore-4.0.0.tar.gz 259755 BLAKE2B 5c4c990c14187c20ef3566d1bc0cf32e50fe108d90b59126e2d56105b6fe053ca02c98e7ad7a4fa09345792106e956873a0f42b8492420bd74898557c6d97f23 SHA512 7e5cf6044a6a7045257b9b9830fe4bdb6fb175240b295da3f93cb0557150536655ddf44ab551b52182815fc517b8e43ee704b1061db1284426574e741f7d9a56
DIST tekore-4.1.0.tar.gz 260732 BLAKE2B 91b9158ee73b8baaaa7134c1c6211a3a491a2669b9b21ed66361d0391d591168eecefe10dfa821a1f6fd9a8e8ab26d166fdf7dfa414b5c1b5d94de6efbea0364 SHA512 424a63d044b0bd9fcf0e3ec0a2ea292860de52ee166a558066b3b5ab382dbf0933116fe0691214e85fdfc10ad3e79cae007876e626e3d61095c63e2765965052
+DIST tekore-4.2.0.tar.gz 261053 BLAKE2B 16e76c7e4ff147140bb5a698381249d135e45cb9bcba23ac14c811bfe220c08e8da003ded44526f5d8f46fc9e439d750c3b21560b38b382751a5d0ee834b72eb SHA512 e22232eb7d4ce453e8338b07caad56b04ec35bf7b4ef2207dae450404e62afaca32b29a74155c99918bea75b0cfb80cc847242ff2ec4762abb8a45c1eb6d6d60
diff --git a/dev-python/tekore/tekore-4.2.0.ebuild b/dev-python/tekore/tekore-4.2.0.ebuild
new file mode 100644
index 000000000000..839a36c242bd
--- /dev/null
+++ b/dev-python/tekore/tekore-4.2.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Spotify Web API client"
+HOMEPAGE="
+ https://tekore.readthedocs.io
+ https://github.com/felix-hilden/tekore
+"
+SRC_URI="https://github.com/felix-hilden/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="0"
+
+RDEPEND="
+ <dev-python/httpx-0.22[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ >=dev-python/pytest-asyncio-0.17[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( readme.rst )
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs/src \
+ dev-python/sphinx_rtd_theme \
+ dev-python/sphinx-autodoc-typehints
+
+EPYTEST_DESELECT=(
+ # Internet
+ tests/auth/expiring.py::TestCredentialsOnline::test_bad_arguments_raises_error
+)