summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-25 07:46:27 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-25 09:12:34 +0200
commit713e0902e4f09bc7ca7b68edb62ea2ec92a57aff (patch)
tree771cd87aa2f8e95ff738ef8254458dd85c0b63cc /dev-python/tekore
parentdev-python/dask: Bump to 2022.05.1 (diff)
downloadgentoo-713e0902e4f09bc7ca7b68edb62ea2ec92a57aff.tar.gz
gentoo-713e0902e4f09bc7ca7b68edb62ea2ec92a57aff.tar.bz2
gentoo-713e0902e4f09bc7ca7b68edb62ea2ec92a57aff.zip
dev-python/tekore: Bump to 4.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tekore')
-rw-r--r--dev-python/tekore/Manifest1
-rw-r--r--dev-python/tekore/tekore-4.4.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/tekore/Manifest b/dev-python/tekore/Manifest
index 6df3da4564e6..17bfa385af37 100644
--- a/dev-python/tekore/Manifest
+++ b/dev-python/tekore/Manifest
@@ -1 +1,2 @@
DIST tekore-4.3.0.tar.gz 261287 BLAKE2B 1ac6f828e20d2aa4e591a7b53f6178d1c9f8b760d2daa1f7705d7a45bef5a4973b65fffc1f7571b1bce270efc9c4e8c6d9dd258173cdda94b06e92a4c14352a2 SHA512 bb0aafdda47d5ac4baefc3c057b8ae91d3a243d913f332f69d7dc00f716e6403daaf8d8382e9b25d2810fd65e139f6d427b9749746c8ac61d67b02dc24620969
+DIST tekore-4.4.0.gh.tar.gz 261768 BLAKE2B b0da919bd0feb32fa5770eb02cd817142d80f63e29602695b7cc6e9099203e502e61aab816ec3586595ab06f7f493243b13dd98cdb9e89913854e7cfcefcfd61 SHA512 86ef782971f1ea9d9f49e9683b27a8d9f70511e89a7fa7c8cffd01ba716782b1d91adcde2e24a52e42ec5b5b936005545ea1e15b067d1f109d2ecd2cebbd930d
diff --git a/dev-python/tekore/tekore-4.4.0.ebuild b/dev-python/tekore/tekore-4.4.0.ebuild
new file mode 100644
index 000000000000..cd7308b5ca24
--- /dev/null
+++ b/dev-python/tekore/tekore-4.4.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Spotify Web API client"
+HOMEPAGE="
+ https://tekore.readthedocs.io/
+ https://github.com/felix-hilden/tekore/
+ https://pypi.org/project/tekore/
+"
+SRC_URI="
+ https://github.com/felix-hilden/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="0"
+
+RDEPEND="
+ <dev-python/httpx-0.24[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ >=dev-python/pytest-asyncio-0.17[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( readme.rst )
+
+distutils_enable_tests pytest
+# TODO: package sphinx_codeautolink
+# distutils_enable_sphinx docs/src \
+# dev-python/sphinx_rtd_theme \
+# dev-python/sphinx-tabs \
+# dev-python/sphinx-autodoc-typehints
+
+EPYTEST_DESELECT=(
+ # Internet
+ tests/auth/expiring.py::TestCredentialsOnline::test_bad_arguments_raises_error
+)