summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-07 06:34:05 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-07 06:34:05 +0100
commitabebc0170a888d60cb0d1b1eddb3436d4055705f (patch)
tree09292b4f87a94a5bf94773eb697b6d3f52d4ef6f /dev-python/tekore
parentdev-python/statsd: Bump to 4.0.1 (diff)
downloadgentoo-abebc0170a888d60cb0d1b1eddb3436d4055705f.tar.gz
gentoo-abebc0170a888d60cb0d1b1eddb3436d4055705f.tar.bz2
gentoo-abebc0170a888d60cb0d1b1eddb3436d4055705f.zip
dev-python/tekore: Bump to 4.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tekore')
-rw-r--r--dev-python/tekore/Manifest1
-rw-r--r--dev-python/tekore/tekore-4.5.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/tekore/Manifest b/dev-python/tekore/Manifest
index 1a5469498e0b..ffadd94bb081 100644
--- a/dev-python/tekore/Manifest
+++ b/dev-python/tekore/Manifest
@@ -1,2 +1,3 @@
DIST tekore-4.4.0.gh.tar.gz 261768 BLAKE2B b0da919bd0feb32fa5770eb02cd817142d80f63e29602695b7cc6e9099203e502e61aab816ec3586595ab06f7f493243b13dd98cdb9e89913854e7cfcefcfd61 SHA512 86ef782971f1ea9d9f49e9683b27a8d9f70511e89a7fa7c8cffd01ba716782b1d91adcde2e24a52e42ec5b5b936005545ea1e15b067d1f109d2ecd2cebbd930d
DIST tekore-4.4.1.gh.tar.gz 261791 BLAKE2B 380685868923bed258739bae67e1d1d57c5cdb23cfb43651c1400a38d40176ba9ad55780e1906b72afc97701918817341e7a2c501c0e7bfb2c57711920877f2e SHA512 f2eb0ee9852d2ef971974871890e5150eecdb30f5894301b22ec728852d680af0d476311b83f3ea4528d4d60cedf5379645aa7ea35015dd8beb1a9a9aeab4671
+DIST tekore-4.5.0.gh.tar.gz 265075 BLAKE2B 830a7c006ea13650ecc639bc8277d7022eed29fb92e13d4ff0bd98cb30f9bf2c53c9fb5dc88f3195938c22e12c8cc73a52517629c1db2d7bdc5e80360ea7b8bc SHA512 c69f47611447fec72fe2c4f09689dc93b8ff4dc94d430f213866b349c5867eeefd5351f3707b05648a74bd30576e4fd5d7e0c81203f5c7f90d54710433e25980
diff --git a/dev-python/tekore/tekore-4.5.0.ebuild b/dev-python/tekore/tekore-4.5.0.ebuild
new file mode 100644
index 000000000000..57eb81c83689
--- /dev/null
+++ b/dev-python/tekore/tekore-4.5.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Spotify Web API client"
+HOMEPAGE="
+ https://tekore.readthedocs.io/
+ https://github.com/felix-hilden/tekore/
+ https://pypi.org/project/tekore/
+"
+SRC_URI="
+ https://github.com/felix-hilden/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="0"
+
+RDEPEND="
+ <dev-python/httpx-0.24[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ >=dev-python/pytest-asyncio-0.17[${PYTHON_USEDEP}]
+ dev-python/pytest-httpx[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( readme.rst )
+
+distutils_enable_tests pytest
+# TODO: package sphinx_codeautolink
+# distutils_enable_sphinx docs/src \
+# dev-python/sphinx_rtd_theme \
+# dev-python/sphinx-tabs \
+# dev-python/sphinx-autodoc-typehints
+
+EPYTEST_DESELECT=(
+ # Internet
+ tests/auth/expiring.py::TestCredentialsOnline::test_bad_arguments_raises_error
+)