summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-15 12:20:43 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-15 12:40:50 +0200
commit13f096a866461bc857bdf2dc7744029478afc5a0 (patch)
tree86ef1bf582d0bab237309f551952bf8f367a60b2 /dev-python/tempest
parentdev-python/pytest: Remove old (diff)
downloadgentoo-13f096a866461bc857bdf2dc7744029478afc5a0.tar.gz
gentoo-13f096a866461bc857bdf2dc7744029478afc5a0.tar.bz2
gentoo-13f096a866461bc857bdf2dc7744029478afc5a0.zip
dev-python/tempest: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tempest')
-rw-r--r--dev-python/tempest/Manifest1
-rw-r--r--dev-python/tempest/tempest-30.0.0.ebuild69
2 files changed, 0 insertions, 70 deletions
diff --git a/dev-python/tempest/Manifest b/dev-python/tempest/Manifest
index 06deed59195f..449bf703f247 100644
--- a/dev-python/tempest/Manifest
+++ b/dev-python/tempest/Manifest
@@ -1,2 +1 @@
-DIST tempest-30.0.0.tar.gz 1110715 BLAKE2B b697ecbced21124719e6b1d7ebd2c4f8ba83528a84da0b8f8109c155b61124581b97c180bbdc6885ae53850fb28daed25772d12be5026c44ecc3fe4f0dad98a3 SHA512 fa9be713ccb130ad065628592f59bebda3dc1fa8222ab3c382ec5b299504dc0a730f2110ef80f98bbdd1288b5785ab745fe39b721b77f7343983c1bc0a036f19
DIST tempest-30.1.0.tar.gz 1112219 BLAKE2B 864dbd01a843b9c480656788a3a673ea6c089af8bf67e66837fdb77ee46eef00f2caed3ee08722b113db45d1e39fee167dcb344676543ec82fe5f022ae8c713d SHA512 3c4469d5ab590fe2185dbe77cc1ca1179022b75b4da9f2fe0d43956b14598d56328dd4e62e8445197b25f93017c812edd75cb9fef2d81ae183aea478fd817b15
diff --git a/dev-python/tempest/tempest-30.0.0.ebuild b/dev-python/tempest/tempest-30.0.0.ebuild
deleted file mode 100644
index 94fc2e0d97c9..000000000000
--- a/dev-python/tempest/tempest-30.0.0.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 2021-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="OpenStack Integration Testing"
-HOMEPAGE="https://pypi.org/project/tempest/ https://docs.openstack.org/tempest/latest/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 x86"
-
-RDEPEND="
- >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
- >dev-python/cliff-2.9.0[${PYTHON_USEDEP}]
- >=dev-python/jsonschema-3.2.0[${PYTHON_USEDEP}]
- >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
- >=dev-python/paramiko-2.7.0[${PYTHON_USEDEP}]
- >=dev-python/netaddr-0.7.18[${PYTHON_USEDEP}]
- >=dev-python/oslo-concurrency-3.26.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-utils-4.7.0[${PYTHON_USEDEP}]
- >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
- >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
- >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
- >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
- >=dev-python/urllib3-1.21.1[${PYTHON_USEDEP}]
- >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
- test? (
- >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
- dev-python/stestr[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests unittest
-
-src_prepare() {
- # Small subset of tests, which fail as result of not using specific
- # testing environment. Others expect to run suite using stestr.
- rm -r tempest/tests/lib/services/volume/v3/ || die
- rm tempest/tests/test_list_tests.py || die
- rm tempest/tests/lib/cmd/test_check_uuid.py || die
-
- # remove dep on hacking
- rm tempest/tests/test_hacking.py || die
-
- distutils-r1_src_prepare
-}
-
-python_test() {
- local -x OS_LOG_CAPTURE=1 OS_STDOUT_CAPTURE=1 OS_STDERR_CAPTURE=1 OS_TEST_TIMEOUT=320
- eunittest -b -s tempest/tests -t .
-}
-
-src_install() {
- distutils-r1_src_install
- mv "${ED}/usr/etc" "${ED}/etc" || die
-}