summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-07-14 21:14:20 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-07-14 21:14:20 +0300
commit30a0a2ebee2804e2fea749a0ce31171603ce5247 (patch)
tree760ece4b11fd367c94d299969a0e6dde1eccce55 /dev-python/tempora/tempora-5.0.2.ebuild
parentdev-libs/libretls-3.5.2: add Prefix keywords (diff)
downloadgentoo-30a0a2ebee2804e2fea749a0ce31171603ce5247.tar.gz
gentoo-30a0a2ebee2804e2fea749a0ce31171603ce5247.tar.bz2
gentoo-30a0a2ebee2804e2fea749a0ce31171603ce5247.zip
dev-python/tempora: add 5.0.2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/tempora/tempora-5.0.2.ebuild')
-rw-r--r--dev-python/tempora/tempora-5.0.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/tempora/tempora-5.0.2.ebuild b/dev-python/tempora/tempora-5.0.2.ebuild
new file mode 100644
index 000000000000..e32d2ca05b4c
--- /dev/null
+++ b/dev-python/tempora/tempora-5.0.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Objects and routines pertaining to date and time"
+HOMEPAGE="https://github.com/jaraco/tempora"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/jaraco-functools-1.20[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pytest-freezegun[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest