summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-10 07:36:11 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-10 07:52:01 +0100
commitdff8c727e4c57df4da1bda743f9e4541144bcab5 (patch)
treed54e015d63818ed014c716ae07b44640ab93a8a8 /dev-python/tenacity/tenacity-8.2.1.ebuild
parentdev-python/zipp: Bump to 3.13.0 (diff)
downloadgentoo-dff8c727e4c57df4da1bda743f9e4541144bcab5.tar.gz
gentoo-dff8c727e4c57df4da1bda743f9e4541144bcab5.tar.bz2
gentoo-dff8c727e4c57df4da1bda743f9e4541144bcab5.zip
dev-python/tenacity: Bump to 8.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tenacity/tenacity-8.2.1.ebuild')
-rw-r--r--dev-python/tenacity/tenacity-8.2.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/tenacity/tenacity-8.2.1.ebuild b/dev-python/tenacity/tenacity-8.2.1.ebuild
new file mode 100644
index 000000000000..2b2710dd1228
--- /dev/null
+++ b/dev-python/tenacity/tenacity-8.2.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="General-purpose retrying library"
+HOMEPAGE="
+ https://github.com/jd/tenacity/
+ https://pypi.org/project/tenacity/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/tornado[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=()
+
+ if ! has_version "dev-python/typeguard[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ tests/test_tenacity.py::TestRetryTyping::test_retry_type_annotations
+ )
+ fi
+
+ epytest
+}