summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2018-02-15 19:25:59 +0100
committerMichał Górny <mgorny@gentoo.org>2018-02-16 17:52:52 +0100
commit0112584b390aa02ab64d4fe096ef5da1c370d306 (patch)
tree8cd361e14cef5ca493812106e544de64784f44b7 /dev-python/terminado/terminado-0.8.1.ebuild
parentdev-python/terminado: Update homepage (diff)
downloadgentoo-0112584b390aa02ab64d4fe096ef5da1c370d306.tar.gz
gentoo-0112584b390aa02ab64d4fe096ef5da1c370d306.tar.bz2
gentoo-0112584b390aa02ab64d4fe096ef5da1c370d306.zip
dev-python/terminado: Version bump to 0.8.1
Closes: https://github.com/gentoo/gentoo/pull/7147 Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'dev-python/terminado/terminado-0.8.1.ebuild')
-rw-r--r--dev-python/terminado/terminado-0.8.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/terminado/terminado-0.8.1.ebuild b/dev-python/terminado/terminado-0.8.1.ebuild
new file mode 100644
index 000000000000..4ee0e36a539d
--- /dev/null
+++ b/dev-python/terminado/terminado-0.8.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Terminals served to term.js using Tornado websockets"
+HOMEPAGE="https://pypi.python.org/pypi/terminado https://github.com/jupyter/terminado"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/ptyprocess[${PYTHON_USEDEP}]
+ >=www-servers/tornado-0.4[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ py.test -v || die
+}