summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-02 18:01:40 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-03 18:21:17 +0100
commit41d96f31a15e354863f7ef9f6527e373c1ad7817 (patch)
tree3471b31c431476d3b83ca6f3db4541d8263a2edb /dev-python/testfixtures
parentdev-python/jedi: Drop unnecessary deps (diff)
downloadgentoo-41d96f31a15e354863f7ef9f6527e373c1ad7817.tar.gz
gentoo-41d96f31a15e354863f7ef9f6527e373c1ad7817.tar.bz2
gentoo-41d96f31a15e354863f7ef9f6527e373c1ad7817.zip
dev-python/testfixtures: Version Bump
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/testfixtures')
-rw-r--r--dev-python/testfixtures/Manifest1
-rw-r--r--dev-python/testfixtures/testfixtures-4.4.0.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/testfixtures/Manifest b/dev-python/testfixtures/Manifest
index 59d16d78d9e1..20ad5742f1fe 100644
--- a/dev-python/testfixtures/Manifest
+++ b/dev-python/testfixtures/Manifest
@@ -2,3 +2,4 @@ DIST testfixtures-3.0.0.tar.gz 75303 SHA256 20e82e23ffc39bd7d55317f2e87e49aa33ac
DIST testfixtures-4.1.1.tar.gz 81356 SHA256 c61b13fd9cac0313e2aafd565a007860d83b218a138117ac421368d2896bc215 SHA512 08785961560218c3a06043158af8364b46b850c159a82e5fd05ccd88133786aed1a0ec9038ef0c0e36430853559e29fefca8f6bfee1b942730010cd3fb8e9ae4 WHIRLPOOL be548f4fa3bf9428cf683d229c9c4569ba2028a05aa284d803a282af293999fd38565f2b9701751c8f84d57faea6efd3a9e1e5ee5375b719957fe6dc7c4cbdf5
DIST testfixtures-4.1.2.tar.gz 81689 SHA256 bc27063ac9bce80ac99fe315f2b34053b113ca420b6bbbaf0c19c49c09bb286a SHA512 bf5171b1e1918e88dd887a7dbca6c340e1c197224135e4080551d1830187aa868e53d8302751059da478e2452b1f68a49ae5fba206e48fec554e6d5f237ee5a4 WHIRLPOOL 8d10fb590bb31ff4b5f24f941c41349ac606d91bf62679f70356cddfbdedb7b64f9addca1a419432987a78ebd520ae5b7ce5ddfb043f6452c3e364f266854ed8
DIST testfixtures-4.3.3.tar.gz 86546 SHA256 ffe66d08ef2fdc0be5e6abe1e1d51384ae941747d3df86d5d8238014b9161f62 SHA512 918fd757c61e4f8b7aa54343036546efab8c014fdaaed1dc5edf6a4b0c636e00396a0400b87a28f0ae43cd318590bf63ff8240e59781f7e183fdd4ebbdac7100 WHIRLPOOL 7d4f2e75c39f8a8ac39cfc577515d9b5b11540b8337f63cb51d75250191d7bcea1d79515b581cb921c7dc273d781c264990118f7ee1cc5579ebd9341097546bf
+DIST testfixtures-4.4.0.tar.gz 87356 SHA256 41096fe91c2939177f1729783bbfaef9e777ba44e7d8ff819ab1318d78beeba7 SHA512 0fdb87e1fd8311cbab274f4db71ec76767cc9e2f771eefb1a110bf42b07e30fc9edbe2db124742b3102b8f114af2666b0b8726f6330871fd72c7ea2f535d5fed WHIRLPOOL 8b5bb18b682f420ae4b66aa1da9ca0f312bff1974400b586cb2bcae635037e629352b37cfa2d1f8c7f91fd880e726c34d7f3aa532b2e04188f5f99ac7a69e2c1
diff --git a/dev-python/testfixtures/testfixtures-4.4.0.ebuild b/dev-python/testfixtures/testfixtures-4.4.0.ebuild
new file mode 100644
index 000000000000..1d295a435e7d
--- /dev/null
+++ b/dev-python/testfixtures/testfixtures-4.4.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A collection of helpers and mock objects for unit tests and doc tests"
+HOMEPAGE="https://pypi.python.org/pypi/testfixtures/ https://github.com/Simplistix/testfixtures"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/pkginfo[${PYTHON_USEDEP}]' python2_7 pypy )
+ )
+ test? (
+ dev-python/manuel[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/nose-cover3[${PYTHON_USEDEP}]
+ dev-python/nose_fixes[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7)
+ )"
+
+python_prepare_all() {
+ # Makefile comes set pointing at a wrong location
+ sed -e 's:../bin/sphinx-build:/usr/bin/sphinx-build:' -i docs/Makefile || die
+ # Prevent un-needed download during build, fix Makefile for doc build
+ sed -e '/'sphinx.ext.intersphinx'/d' -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_prepare() {
+ # remove test that tests the stripped zope-component test_components.ComponentsTests
+ rm -f testfixtures/tests/test_components.py || die
+
+ distutils-r1_python_prepare
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ nosetests --verbose || die
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}