summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-17 19:39:47 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-17 20:06:50 +0200
commit22c1a3498b1604f8e12a6a1e3589ccc5af76f593 (patch)
tree1f8afc5340cab4bbe7b2aa3446fdd64dc8c61b40 /dev-python/testpath/testpath-0.5.0.ebuild
parentdev-python/pyproject2setuppy: Bump to v15 (diff)
downloadgentoo-22c1a3498b1604f8e12a6a1e3589ccc5af76f593.tar.gz
gentoo-22c1a3498b1604f8e12a6a1e3589ccc5af76f593.tar.bz2
gentoo-22c1a3498b1604f8e12a6a1e3589ccc5af76f593.zip
dev-python/testpath: Bump to 0.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/testpath/testpath-0.5.0.ebuild')
-rw-r--r--dev-python/testpath/testpath-0.5.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/testpath/testpath-0.5.0.ebuild b/dev-python/testpath/testpath-0.5.0.ebuild
new file mode 100644
index 000000000000..44cf89905b50
--- /dev/null
+++ b/dev-python/testpath/testpath-0.5.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( pypy3 python3_{7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Test utilities for code working with files and commands"
+HOMEPAGE="https://github.com/jupyter/testpath https://testpath.readthedocs.io/en/latest/"
+SRC_URI="https://github.com/jupyter/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ >=dev-python/pyproject2setuppy-15
+ test? (
+ dev-python/pathlib2[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc