summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-03 13:13:42 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-03 13:16:59 +0100
commitebc0f971f94ce78032b4bf3a20c3a9bce60095ee (patch)
treeab21f0b3d2418286e9e4762a50cccbc81918a1d5 /dev-python/testrepository/testrepository-0.0.18-r1.ebuild
parentdev-python/testrepository: Drop old (diff)
downloadgentoo-ebc0f971f94ce78032b4bf3a20c3a9bce60095ee.tar.gz
gentoo-ebc0f971f94ce78032b4bf3a20c3a9bce60095ee.tar.bz2
gentoo-ebc0f971f94ce78032b4bf3a20c3a9bce60095ee.zip
dev-python/testrepository: Backport test fixes
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=537536 Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/testrepository/testrepository-0.0.18-r1.ebuild')
-rw-r--r--dev-python/testrepository/testrepository-0.0.18-r1.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-python/testrepository/testrepository-0.0.18-r1.ebuild b/dev-python/testrepository/testrepository-0.0.18-r1.ebuild
index 3771a4137fae..0b287e877a49 100644
--- a/dev-python/testrepository/testrepository-0.0.18-r1.ebuild
+++ b/dev-python/testrepository/testrepository-0.0.18-r1.ebuild
@@ -34,9 +34,15 @@ DEPEND="
# Required for test phase
DISTUTILS_IN_SOURCE_BUILD=1
+PATCHES=(
+ "${FILESDIR}"/${P}-test-backport.patch
+ "${FILESDIR}"/${PN}-0.0.20-test-backport1.patch
+)
+
python_test() {
# some errors appear to have crept in the suite undert py3 since addition.
# Python2.7 now passes all.
- esetup.py testr --coverage
+ ${PYTHON} testr init || die
+ ${PYTHON} testr run || die
}