summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-11 12:50:10 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-11 13:24:29 +0200
commit0490f04def6899404e33e2dbbd28787cab38330f (patch)
tree6770ab96cea66eeb3d3038c80002ae9e8976935f /dev-python/testscenarios
parentdev-python/snowballstemmer: Add python3.5 support (diff)
downloadgentoo-0490f04def6899404e33e2dbbd28787cab38330f.tar.gz
gentoo-0490f04def6899404e33e2dbbd28787cab38330f.tar.bz2
gentoo-0490f04def6899404e33e2dbbd28787cab38330f.zip
dev-python/testscenarios: Add python3.5 support
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/testscenarios')
-rw-r--r--dev-python/testscenarios/testscenarios-0.5.0-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/testscenarios/testscenarios-0.5.0-r1.ebuild b/dev-python/testscenarios/testscenarios-0.5.0-r1.ebuild
new file mode 100644
index 000000000000..f7be22fe65b8
--- /dev/null
+++ b/dev-python/testscenarios/testscenarios-0.5.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A pyunit extension for dependency injection"
+HOMEPAGE="https://launchpad.net/testscenarios"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="dev-python/testtools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.11[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ # Remove a faulty file from tests, missing a required attribute
+ rm ${PN}/tests/test_testcase.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${PYTHON}" -m unittest discover
+}