summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/testscenarios
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/testscenarios')
-rw-r--r--dev-python/testscenarios/Manifest2
-rw-r--r--dev-python/testscenarios/metadata.xml21
-rw-r--r--dev-python/testscenarios/testscenarios-0.4-r2.ebuild27
-rw-r--r--dev-python/testscenarios/testscenarios-0.4-r4.ebuild24
-rw-r--r--dev-python/testscenarios/testscenarios-0.4-r5.ebuild24
-rw-r--r--dev-python/testscenarios/testscenarios-0.4.ebuild28
-rw-r--r--dev-python/testscenarios/testscenarios-0.5.0.ebuild31
7 files changed, 157 insertions, 0 deletions
diff --git a/dev-python/testscenarios/Manifest b/dev-python/testscenarios/Manifest
new file mode 100644
index 000000000000..0c854c3c337d
--- /dev/null
+++ b/dev-python/testscenarios/Manifest
@@ -0,0 +1,2 @@
+DIST testscenarios-0.4.tar.gz 22768 SHA256 4feeee84f7fd8a6258fc00671e1521f80cb68d2fec1e2908b3ab52bcf396e198 SHA512 1b3fbc11b0a6a9cdd4afd569374cde92c291d925f76295e191b91285e88c17a9e693e10972538d146f97c889c5c1fa4545c79b0e6b9d71265abc82cf2700a3f9 WHIRLPOOL fe8769be1ccbeda81dc8f5f19f0e74a1ab616eac1389dca487427d77ddbf25f5c569445fb4e3f3732c117d61b0c22588ae2b8334cfb5b68afa227ee51bf8dc10
+DIST testscenarios-0.5.0.tar.gz 20951 SHA256 c257cb6b90ea7e6f8fef3158121d430543412c9a87df30b5dde6ec8b9b57a2b6 SHA512 f08b868babf504482369c5cb945d3e95bca1cc00f92d5013f6898c488051be0c26dc49aaabcef362aea45450a8d041d9826fb6b5c848beec013fb102d6935521 WHIRLPOOL 7b02c7a61933a8e603074321e0b4357485dad72ccffca5b28fc423da76159e6c8a4d778a431d607bff43563bc6971d66d38d7e3f89973f9c2838e569a947c0c1
diff --git a/dev-python/testscenarios/metadata.xml b/dev-python/testscenarios/metadata.xml
new file mode 100644
index 000000000000..5c275d80b9bf
--- /dev/null
+++ b/dev-python/testscenarios/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>openstack</herd>
+ <herd>python</herd>
+ <maintainer>
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ Testscenarios provides clean dependency injection for
+ python unittest style tests. This can be used for interface testing
+ (testing many implementations via a single test suite) or for classic
+ dependency injection (provide tests with dependencies externally to the
+ test code itself, allowing easy testing in different situations).
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">testscenarios</remote-id>
+ <remote-id type="launchpad">testscenarios</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/testscenarios/testscenarios-0.4-r2.ebuild b/dev-python/testscenarios/testscenarios-0.4-r2.ebuild
new file mode 100644
index 000000000000..2514e5892cad
--- /dev/null
+++ b/dev-python/testscenarios/testscenarios-0.4-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Testscenarios, a pyunit extension for dependency injection"
+HOMEPAGE="https://launchpad.net/testscenarios"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}] )"
+# dev-python/testresources[${PYTHON_USEDEP}]
+RDEPEND=""
+
+python_test() {
+ PYTHONPATH=./lib ${EPYTHON} -m testtools.run testscenarios.test_suite
+}
diff --git a/dev-python/testscenarios/testscenarios-0.4-r4.ebuild b/dev-python/testscenarios/testscenarios-0.4-r4.ebuild
new file mode 100644
index 000000000000..85d952d483ba
--- /dev/null
+++ b/dev-python/testscenarios/testscenarios-0.4-r4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Testscenarios, a pyunit extension for dependency injection"
+HOMEPAGE="https://launchpad.net/testscenarios"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="dev-python/testtools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ PYTHONPATH=./lib ${EPYTHON} -m testtools.run testscenarios.test_suite
+}
diff --git a/dev-python/testscenarios/testscenarios-0.4-r5.ebuild b/dev-python/testscenarios/testscenarios-0.4-r5.ebuild
new file mode 100644
index 000000000000..fab332d8a577
--- /dev/null
+++ b/dev-python/testscenarios/testscenarios-0.4-r5.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Testscenarios, a pyunit extension for dependency injection"
+HOMEPAGE="https://launchpad.net/testscenarios"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="dev-python/testtools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ PYTHONPATH=./lib ${EPYTHON} -m testtools.run testscenarios.test_suite
+}
diff --git a/dev-python/testscenarios/testscenarios-0.4.ebuild b/dev-python/testscenarios/testscenarios-0.4.ebuild
new file mode 100644
index 000000000000..f50754fa736f
--- /dev/null
+++ b/dev-python/testscenarios/testscenarios-0.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Testscenarios, a pyunit extension for dependency injection"
+HOMEPAGE="https://launchpad.net/testscenarios"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ dev-python/testresources[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+python_test() {
+ # https://bugs.launchpad.net/testscenarios/+bug/1260573
+ nosetests || die "Tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/testscenarios/testscenarios-0.5.0.ebuild b/dev-python/testscenarios/testscenarios-0.5.0.ebuild
new file mode 100644
index 000000000000..5a70e5f2727d
--- /dev/null
+++ b/dev-python/testscenarios/testscenarios-0.5.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Testscenarios, a pyunit extension for dependency injection"
+HOMEPAGE="https://launchpad.net/testscenarios"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="dev-python/testtools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.11[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ # Remove a faulty file from tests, missing a required attribute
+ rm ${PN}/tests/test_testcase.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${PYTHON}" -m unittest discover
+}