summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-06 00:23:15 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-06 00:54:07 +0200
commit3b781a3520fd39359421116ac0e4f7822778c5ed (patch)
tree766ddc5be204b7fc4441f239bc276995964a211a /dev-python/testtools
parentdev-python/testtools: Stabilize 2.4.0-r2 ALLARCHES (diff)
downloadgentoo-3b781a3520fd39359421116ac0e4f7822778c5ed.tar.gz
gentoo-3b781a3520fd39359421116ac0e4f7822778c5ed.tar.bz2
gentoo-3b781a3520fd39359421116ac0e4f7822778c5ed.zip
dev-python/testtools: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/testtools')
-rw-r--r--dev-python/testtools/testtools-2.4.0-r1.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/dev-python/testtools/testtools-2.4.0-r1.ebuild b/dev-python/testtools/testtools-2.4.0-r1.ebuild
deleted file mode 100644
index 7ac7bd38f4e7..000000000000
--- a/dev-python/testtools/testtools-2.4.0-r1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..9} pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Extensions to the Python standard library unit testing framework"
-HOMEPAGE="https://github.com/testing-cabal/testtools"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
-
-RDEPEND="
- >=dev-python/extras-1.0.0[${PYTHON_USEDEP}]
- dev-python/python-mimeparse[${PYTHON_USEDEP}]
- >=dev-python/pbr-0.11[${PYTHON_USEDEP}]
- dev-python/pyrsistent[${PYTHON_USEDEP}]
- >=dev-python/six-1.4.0[${PYTHON_USEDEP}]
- dev-python/traceback2[${PYTHON_USEDEP}]
- >=dev-python/unittest2-1.0.0[${PYTHON_USEDEP}]
-"
-DEPEND="
- test? (
- >=dev-python/fixtures-1.3.0[${PYTHON_USEDEP}]
- dev-python/testscenarios[${PYTHON_USEDEP}]
- )
-"
-PDEPEND=">=dev-python/fixtures-1.3.0[${PYTHON_USEDEP}]"
-
-PATCHES=(
- "${FILESDIR}"/testtools-2.4.0-py39.patch
-)
-
-distutils_enable_sphinx doc
-distutils_enable_tests unittest
-
-python_test() {
- "${PYTHON}" -m testtools.run testtools.tests.test_suite || die "tests failed under ${EPYTHON}"
-}