summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-12 04:12:13 +0100
committerSam James <sam@gentoo.org>2021-07-12 04:13:52 +0100
commit3be57e9c52fe2103d46ff42c8e5b4d048b09217e (patch)
tree913b263e9b515d51d6a8b34f52c6ace4507836b5 /dev-python/testtools
parentapp-crypt/certbot-nginx: 1.17.0 bump (diff)
downloadgentoo-3be57e9c52fe2103d46ff42c8e5b4d048b09217e.tar.gz
gentoo-3be57e9c52fe2103d46ff42c8e5b4d048b09217e.tar.bz2
gentoo-3be57e9c52fe2103d46ff42c8e5b4d048b09217e.zip
dev-python/testtools: drop back to EAPI 7 to ease upgrades
This causes an issue because of the following depchain: samba -> subunit -> testtools (EAPI 8 only) While we should try drop the subunit dependency from Samba if possible, let's drop testtools back to EAPI 7 temporarily to ease upgrades for users, given Samba is a very common package (and even dependency). Bug: https://bugs.gentoo.org/801637 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/testtools')
-rw-r--r--dev-python/testtools/testtools-2.4.0-r2.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/testtools/testtools-2.4.0-r2.ebuild b/dev-python/testtools/testtools-2.4.0-r2.ebuild
index fdc73ff2db99..7f2830ce2d40 100644
--- a/dev-python/testtools/testtools-2.4.0-r2.ebuild
+++ b/dev-python/testtools/testtools-2.4.0-r2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=8
+EAPI=7
PYTHON_COMPAT=( python3_{8..10} pypy3 )
PYTHON_REQ_USE="threads(+)"
@@ -43,6 +43,10 @@ distutils_enable_tests unittest
src_prepare() {
# eliminate unittest2 & traceback2
sed -i -e '/unittest2/d' -e '/traceback2/d' requirements.txt || die
+ # eliminate linecache2
+ sed -i -e 's/import linecache2 as linecache/import linecache/' \
+ testtools/tests/test_compat.py || die
+
# also conditional imports
find -name '*.py' -exec \
sed -i -e 's:unittest2:unittest:' {} + || die