summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-02 08:49:12 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-02 09:50:41 +0200
commit99e1be8347c55a8c63d7d160521d09e9d3db9673 (patch)
treeb6cdb05798b813c7a7006e98cd1c421787330464 /dev-python/threadpoolctl
parentdev-python/pydata-sphinx-theme: Bump to 0.7.0 (diff)
downloadgentoo-99e1be8347c55a8c63d7d160521d09e9d3db9673.tar.gz
gentoo-99e1be8347c55a8c63d7d160521d09e9d3db9673.tar.bz2
gentoo-99e1be8347c55a8c63d7d160521d09e9d3db9673.zip
dev-python/threadpoolctl: Bump to 3.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/threadpoolctl')
-rw-r--r--dev-python/threadpoolctl/Manifest1
-rw-r--r--dev-python/threadpoolctl/threadpoolctl-3.0.0.ebuild20
2 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/threadpoolctl/Manifest b/dev-python/threadpoolctl/Manifest
index feec594f15c6..31c4928cac82 100644
--- a/dev-python/threadpoolctl/Manifest
+++ b/dev-python/threadpoolctl/Manifest
@@ -1 +1,2 @@
DIST threadpoolctl-2.2.0.tar.gz 25875 BLAKE2B 4fc77efb181a91888d2d47cf1f9fa67157366e3ce33a958244b606019389624e83b1903581bfe88f8b4c798b4a8f07d0a50269282efaa323d3cae9f3d5ea8258 SHA512 edc310a9447b1782cedc98aadd065ce9291eca04518f6223090c1dd57f714b85f32293f16cfc1d95639130db47aa04806cac77a42922471e07582293416450fc
+DIST threadpoolctl-3.0.0.tar.gz 28486 BLAKE2B e49bf43ea272e353e1a5f864cd7f38978793489b2dba60a1c075a61f6dbfe0a75a456e1143c0f33d3222ff2e27c1ce6025579b00e3feb2d789c7be068f6e07ad SHA512 df0829d5bed15d5cbcd502810aff91c9dd0d4dafc11173aa762426e96a7ed5acb0fd3132161e5b2d234136156f2a599c3592fc0a8e20828db83882b840a939cc
diff --git a/dev-python/threadpoolctl/threadpoolctl-3.0.0.ebuild b/dev-python/threadpoolctl/threadpoolctl-3.0.0.ebuild
new file mode 100644
index 000000000000..4e259103e370
--- /dev/null
+++ b/dev-python/threadpoolctl/threadpoolctl-3.0.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+inherit distutils-r1
+
+DESCRIPTION="Limit the number of threads used in native libs that have their own threadpool"
+HOMEPAGE="https://github.com/joblib/threadpoolctl"
+SRC_URI="https://github.com/joblib/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest